Ask Your Question
1

Error while installing puppet server on RHEL 6.4

asked 2014-12-10 16:56:26 -0500

vineeth.linux gravatar image

updated 2014-12-10 21:39:14 -0500

GregLarkin gravatar image
Error: Package: rubygem-json-1.5.5-3.el6.x86_64 (puppetlabs-deps)
    Requires: rubygems >= 1.3.7

I do have ruby and gem on my system :

ruby 2.0.0p353 (2013-11-22 revision 43784) [x86_64-linux] 
gem 2.1.7

Please let me know if anyone came across this issue.

edit retag flag offensive close merge delete

Comments

Do you have the rubygems package installed, though? What is the output of "rpm -qa | grep rubygems"?

GregLarkin gravatar imageGregLarkin ( 2014-12-10 21:40:14 -0500 )edit

Greg, I didn't get any result after running the above command.

vineeth.linux gravatar imagevineeth.linux ( 2014-12-11 03:05:04 -0500 )edit

1 Answer

Sort by ¬Ľ oldest newest most voted
1

answered 2014-12-11 03:15:43 -0500

domcleal gravatar image

updated 2014-12-12 06:20:08 -0500

The rubygems package is provided in RHEL's optional repository/channel, which you need to enable.

If you're using RHN with subscription-manager, run:

subscription-manager repos --enable=rhel-6-server-optional-rpms

If you're using Satellite 5, then ensure you have the child channel synced, then add it to your host from the UI or the rhn-channel command.

Edit: I just noticed your ruby and gem output in the question. Those are not from the EL6 distro, so you might well encounter problems if you've replaced the default Ruby version as packages are not built for your custom version.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2014-12-10 16:53:48 -0500

Seen: 340 times

Last updated: Dec 12 '14