Ask Your Question
1

Puppet Error During Quick Start RHEL6 and 7

asked 2014-12-11 13:27:11 -0600

talal234 gravatar image

Hello I'm getting the following error during the quick start of the latest version of puppet 3.7. !ERROR: The puppet master service failed to start within 120 seconds.The logs don't show anything specific. I basically see a bunch of curl statements then the error message. After that Puppet is in a bad state and all I can really do is uninstall and go through the process again which fails.

* curl --tlsv1 -s https://xxx.xxx.xxx:8140 * curl --tlsv1 -s https://xxx.xxx.xxx:8140 * curl --tlsv1 -s https://xxx.xxx.xxx:8140 * curl --tlsv1 -s https://xxx.xxx.xxx:8140 ** curl --tlsv1 -s https://xxx.xxx.xxx:8140

======================================================================== !! ERROR: The puppet master service failed to start within 120 seconds; unable to proceed

edit retag flag offensive close merge delete

Comments

is this trying to connect to the console? do you have iptables or a firewall running blocking any ports (obviously 8140, but also 61613,443) is the curl statement above using a hostname (where you have the xxx's?) - if so can you resolve these hostnames from the command line?

sahumphries gravatar imagesahumphries ( 2014-12-15 06:46:04 -0600 )edit

I would love to know the answer to this too. This has been plaguing me for weeks and I can't finish the install as it always get stuck at the same place. Anyone find a work around?

Element20Three gravatar imageElement20Three ( 2014-12-29 16:22:10 -0600 )edit

I'm experiencing the exact same issues. Iptables are completely off. Tried about a dozen times on different vms and same result.

Element20Three gravatar imageElement20Three ( 2014-12-29 16:23:18 -0600 )edit

I'm getting the same error, has anyone fixed it? I'm stuck on that and i can`t advance.. Environment: RHEL 6.6 Puppet enterprise 3.7.2 8140, 61613, 443 opened ports "Unsetted" https and http proxies Thanks in advance

esierra gravatar imageesierra ( 2015-03-20 06:14:11 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2015-05-19 04:46:39 -0600

I was getting this error while installing on Ubuntu 14.04 Server. I installed the below package before running the installer and after this I was able to install successfully:

Install packages which are not in PE installer dependency:

apt-get install zlib1g-dev build-essential libssl-dev libreadline-dev libyaml-dev libsqlite3-dev sqlite3 libxml2-dev libxslt1-dev libcurl4-openssl-dev python-software-properties

edit flag offensive delete link more
0

answered 2015-01-27 10:02:31 -0600

I had the same issue. If you unset the 'https_proxy' setting on the box prior to running the update it will be fine. In my case the Puppet install was hitting the configured external squid proxy.

So:

unset http_proxy

unset https_proxy

Run the upgrade, hopefully successfully!

And re-apply your proxy settings once more.

export http_proxy=<proxy:port>

export https_proxy=<proxy:port>
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2014-12-11 13:27:11 -0600

Seen: 832 times

Last updated: Dec 15 '14