Ask Your Question

Local ip for ovs agent must be set when tunneling is enabled

asked 2014-12-12 23:18:32 -0600

MOHAN gravatar image

I am trying to install openstack on multiple hosts. My hosts are configured as VMs in the virtual box and I am running Ubuntu 14.04 server. I am following the configurations that was mentioned at

I am using the common.yaml file from this link and only change I made is the IP addresses for Contoller and Storage nodes. The final digits will be .11 for Controller and .31 for the Storage.

openstack::region: 'openstack'

######## Networks openstack::network::api: '' openstack::network::external: '' openstack::network::management: '' openstack::network::data: ''

openstack::network::external::ippool::start: openstack::network::external::ippool::end: openstack::network::external::gateway: openstack::network::external::dns:

######## Private Neutron Network

openstack::network::neutron::private: ''

######## Fixed IPs (controllers)

openstack::controller::address::api: '' openstack::controller::address::management: '' openstack::storage::address::api: '' openstack::storage::address::management: ''

After I classified the node as Contoller from the Puppet Enterprise and ran “puppet agent -t” command, I got the following errors.

puppet agent -t

Info: Retrieving pluginfacts Info: Retrieving plugin Info: Loading facts Could not retrieve fact='aptupdates', resolution='<anonymous>': can't convert nil into Integer Could not retrieve fact='aptsecurity_updates', resolution='<anonymous>': can't convert nil into Integer Error: Could not retrieve catalog from remote server: Error 400 on SERVER: Local ip for ovs agent must be set when tunneling is enabled at /etc/puppetlabs/puppet/environments/production/modules/neutron/manifests/agents/ml2/ovs.pp:107 on node control Warning: Not using cache on failed catalog Error: Could not retrieve catalog; skipping run The ip addresses are configured on the controller node at /etc/networks/interfaces are:

cat /etc/network/interfaces

This file describes the network interfaces available on your system

and how to activate them. For more information, see interfaces(5).

The loopback network interface

auto lo iface lo inet loopback

Management network

auto eth0 iface eth0 inet static address netmask

API network

auto eth1 iface eth1 inet static address netmask

The primary network interface

#auto eth2 #iface eth2 inet dhcp

The interfaces are also up.

ifconfig eth0 Link encap:Ethernet HWaddr 08:00:27:11:57:4b
inet addr: Bcast: Mask: inet6 addr: fe80::a00:27ff:fe11:574b/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:339 errors:0 dropped:0 overruns:0 frame:0 TX packets:315 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:240373 (240.3 KB) TX bytes:135372 (135.3 KB)

eth1 Link encap:Ethernet ...

edit retag flag offensive close merge delete


Did you ever find a solution? I have the same error and my configuration is similar. IP addresses configured and up, but get this error on the controller node.

Marc Runkel gravatar imageMarc Runkel ( 2014-12-28 06:22:11 -0600 )edit

1 Answer

Sort by » oldest newest most voted

answered 2014-12-28 10:11:23 -0600

I figured this out.

Contrary to the included documentation image, your controller needs an IP in the data network (which is shown on the diagram as only existing between the neutron router and the compute hosts.

I added it as an alias to the management network interface and the installation proceeded. It's unclear if it needs to be in the actual data network or not.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2014-12-12 23:18:32 -0600

Seen: 994 times

Last updated: Dec 28 '14