Ask Your Question
0

unable to connect to puppetdb server: SSL_connect SYSCALL returned=5

asked 2014-12-13 07:14:41 -0500

Yeayu gravatar image

updated 2014-12-14 14:15:28 -0500

Hello all,

I am having problems connecting to puppetdb. The puppetdb installation (using the puppetmodule) seems to go as expected, however it is unable to connect to the db, reporting the following:

Notice: Failed to connect to puppetdb; sleeping 2 seconds before retry
Notice: Unable to connect to puppetdb server (puppetmaster.mydomain.local:5432): SSL_connect SYSCALL returned=5 errno=0 state=SSLv2/v3 read server hello A
Notice: Failed to connect to puppetdb; sleeping 2 seconds before retry

I have installed the puppetdb on the same puppet master server, as follows:

node 'puppetmaster.mydomain.local'{
        class {'puppetdb':
        listen_address => '*',
        ssl_listen_address => '0.0.0.0',
        }
        class {'puppetdb::master::config':
        puppetdb_port => 5432,}
}

In case I have not said it yet, I have configured my puppet master open source with apache passenger.

any help would be much appreciated.

edit retag flag offensive close merge delete

Comments

Are you sure that there is no problem with DNS resolving, Firewall configuration etc.? Check with tcpdump, if there are packages received on PuppetDB side

Tomasz Olszewski gravatar imageTomasz Olszewski ( 2014-12-14 05:10:20 -0500 )edit

puppetdb is installed in the same puppetmaster server, which resolves either by using fqdn, netbios or even localhost. Iptables/selinux is disabled and I can see that puppetdb is listening on port 5432 (lsof -i :5432)

Yeayu gravatar imageYeayu ( 2014-12-14 07:26:22 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-12-13 10:18:39 -0500

have you tried: puppetdb-ssl-setup -f - then restart puppetdb?

edit flag offensive delete link more

Comments

yes, I ran puppetdb-ssl-setup in my attempt to solve it, however I did not use -f option. I will try again and see how it goes. On the other hand, should i configure something else regarding SSL within puppetdb blass in my manifest?

Yeayu gravatar imageYeayu ( 2014-12-14 07:28:46 -0500 )edit

An update on this: After running the command listed above, i receive the same error.

Yeayu gravatar imageYeayu ( 2014-12-14 11:23:21 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

3 followers

Stats

Asked: 2014-12-13 07:14:41 -0500

Seen: 1,212 times

Last updated: Dec 14 '14