Ask Your Question
2

Learning VM IP address is not getting assigned

asked 2014-12-19 07:06:41 -0500

debajyoti gravatar image

after booting the learning VM,IP address is not showing.

facter ipaddress output is empty.

edit retag flag offensive close merge delete

5 Answers

Sort by ยป oldest newest most voted
0

answered 2014-12-21 05:17:22 -0500

confiq gravatar image

I'm having similar problem even when DHCP server is working well. However, I did fix it by running DHCP client on VM terminal. dhclient. I hope it helps

edit flag offensive delete link more
0

answered 2016-09-23 08:57:48 -0500

jlackman gravatar image

So, I'm being encouraged to get familiar with Puppet at work. So I go to download the Learning VM. That page didn't work. So I contacted several contacts at Puppet. Now I get the .ova and boot it; Now I have followed the instructions and with a bridge connection, no IP is assigned. With NAT or Host-Only, I get an IP but cannot connect via SSH and I cannot connect to the IP via a browser either. So, what should be a simple setup to train puppet has turned into a troubleshooting saga. Not cool.

edit flag offensive delete link more
0

answered 2014-12-20 02:46:39 -0500

Walid Shaari gravatar image

how about the OS command /sbin/ifconfig? does it show you have an address, did you set an address /etc/hosts ?

edit flag offensive delete link more

Comments

fconfig show eth1 (without address) and loopback interfaces.As per the quest guide, it should show the address after isssuing facter ipaddress_eth0 , but showing nothing. there is no eth0 interface. Bridge network adapter selected for the VM as per the guide. I have tried assigning IP manually, but

debajyoti gravatar imagedebajyoti ( 2014-12-20 14:14:20 -0500 )edit

check your dhcp client, check that you image does not have a mac address different than what udev rules is referencing, you have to have the ipaddress assigned to the interface for facter ipaddress to work

Walid Shaari gravatar imageWalid Shaari ( 2014-12-28 22:08:37 -0500 )edit
0

answered 2015-09-04 04:28:33 -0500

valsaraj007 gravatar image

I had this issue when bridged adapter is set. When it changed to NAT or Host-Only it worked. In case of NAT we can't access from outside. So when I set Host-Only, I am able to access quest from host OS.

edit flag offensive delete link more
0

answered 2014-12-20 14:13:44 -0500

debajyoti gravatar image

ifconfig show eth1 (without address) and loopback interfaces.As per the quest guide, it should show the address after isssuing facter ipaddress_eth0 , but showing nothing. there is no eth0 interface. Bridge network adapter selected for the VM as per the guide. I have tried assigning IP manually, but not able to connect through SSH.Also editted /etc/sysconfig/network-scripts/ifcfg-eth0, but nothing worked.

edit flag offensive delete link more

Comments

you can't answer yourself like this. You can answer specific answer.

confiq gravatar imageconfiq ( 2014-12-29 05:04:31 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2014-12-19 07:06:41 -0500

Seen: 1,754 times

Last updated: Sep 23 '16