Ask Your Question
0

How to configure Puppetdb module to not start/refresh puppet master service

asked 2015-01-07 08:51:40 -0500

umairch gravatar image

updated 2015-01-07 09:46:28 -0500

GregLarkin gravatar image

I have installed puppet master with passenger apache and running it through httpd service [ofcourse disabled puppetmaster service] but when apply below manifest puppet db module starts the /etc/init.d/puppetmaster service, how do i disable this.

node 'puppetmaster-lhr.i2cinc.com' {
class { 'puppetdb':
        database_username => puppetdb,
       database_password => puppetdb,
        database_name     => puppetdb,
        report_ttl        => '7d',
        listen_port     => 8080,
        ssl_listen_address => 'puppetmaster-lhr.i2cinc.com',
        ssl_listen_port => 8081,
        manage_dbserver => true,
        database        => postgres,
        database_host   => localhost,
        database_port   => 5432,
        gc_interval     => 60,
        puppetdb_service => puppetdb,
        puppetdb_service_status => running,
        listen_address  => 'puppetmaster-lhr.i2cinc.com'

    }
    class { 'puppetdb::master::config':
        manage_report_processor => true,
        enable_reports          => true,
        puppetdb_port           => 8081,
        manage_routes           => true,
        manage_config           => true

    }
}
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-01-08 03:55:43 -0500

umairch gravatar image

Updated the class puppetd::master::config by adding following to it. Solved the issue restart_puppet => false

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-01-07 08:51:40 -0500

Seen: 99 times

Last updated: Jan 08 '15