Ask Your Question
0

Passenger fails to load the puppet master app

asked 2015-01-07 09:35:04 -0500

umairch gravatar image

updated 2015-01-07 10:27:43 -0500

domcleal gravatar image
[root@puppetmaster-lhr ~]# passenger-status
Version : 4.0.57
Date    : Wed Jan 07 15:31:13 +0500 2015
Instance: 2071
----------- General information -----------
Max pool size : 6
Processes     : 0
Requests in top-level queue : 0

----------- Application groups -----------

Although it was working fine at first but after installation of puppetdb via module, puppet master app is not being loaded by passenger, however i have seen that port 8140 is listening

edit retag flag offensive close merge delete

Comments

Logs? Apache errors logs specifically, but syslog may be useful too.

domcleal gravatar imagedomcleal ( 2015-01-07 10:28:08 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-01-08 03:53:48 -0500

umairch gravatar image

After reading passenger official documentation i found that Phusion Passenger only starts your application the first time it is accessed, not during web server startup. so i ran puppet agent --test at the master and passenger status output showed that app has been loaded.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2015-01-07 09:35:04 -0500

Seen: 68 times

Last updated: Jan 08 '15