Ask Your Question
0

Cannot change ntp server from the console (getting started with puppet)

asked 2015-01-14 04:36:12 -0500

dogfish182 gravatar image

updated 2015-01-14 07:39:47 -0500

Hello all,

Beginner puppet enterprise 3.7 user here. Have setup my infrastructure with a monolithic install and managing 5 nodes. everything seems great however in the documentation for puppet getting started

here https://docs.puppetlabs.com/pe/latest/quickstartntp.html

I followed this through and configured ntp for my environment for all default nodes. I was happy to see that changes were made on all 5 servers and the config files were updated. HOWEVER, it never updates my ntp servers to the option I configured in classes -> Class ntp -> servers I added exactly one server and this value is never updated. I'm very confused as to why. I've tried changing the value and redoing puppet runs, but it's never updating. I just have the default debian servers being populated.

I've confirmed that ntp module is correctly managing the servers by stopping ntp service on nodes and doing a puppet run. they all start again, but my servers never get updated in the config file.

do I miss something simple here? To be sure, I've tried populating/changing/adding/removing about 10 times over. this variable seems to be entirely ignored always.

EDIT: I found that there is indeed a log with an error that reports

err Could not retrieve catalog from remote server: Error 400 on SERVER: "server.blah.com" is not an Array. It looks to be a String at /etc/puppetlabs/puppet/environments/production/modules/ntp/manifests/init.pp:44 on node sv-ams-es01.debisair.loc .

the trouble is that as soon as I even type 1 character in the Value field of the console, 'Converted to string' pops up beside it with the info Structured parameters Class parameters can be structured as JSON. If we can't parse your parameter as JSON we'll send it to the classifier service as a string.

so I guess my question is, how do I pass my 1 server as an array that the GUI will accept? the format I'm trying is ['0.debian.pool.ntp.org'] but pasting that in directly makes it a string. Is this a bug?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2015-01-14 08:28:22 -0500

dogfish182 gravatar image

alright. It's a bit of an echo chamber in here, but since I'm sure there will be another puppet noob out there somewhere that trips over this like I did, I made it work by passing my servers in the following format

["ntp01.server.com", "ntp02.server.com"]

my puppet now happily manages my server lists.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-01-14 04:36:12 -0500

Seen: 587 times

Last updated: Jan 14 '15