Ask Your Question
0

unable to define basemodulepath

asked 2015-01-30 12:50:23 -0500

racecarpassenger32 gravatar image

updated 2015-01-30 13:19:27 -0500

I recently installed Puppet and I'm having a hard time defining basemodulepath. I try to define it in puppet.conf but whenever I run:

puppet config print basemodulepath

I receive:

invalid parameter: basemodulepath

From Puppet documentation, it seems that basemodulepath is available as of version 3.3, so I believe it should be available in the version of Puppet that I installed from the Pidora repository (version 3.4.3).

Name        : puppet-server
Arch        : noarch
Version     : 3.4.3
Release     : 3.fc20
Size        : 5.7 k
Repo        : installed
From repo   : pidora-updates
Summary     : Server for the puppet system management tool
URL         : http://puppetlabs.com
License     : ASL 2.0
Description : Provides the central puppet server daemon which provides manifests to clients.
            : The server can also function as a certificate authority and file server.

I have tried to define it everywhere I can think. Here is a copy of my current puppet.conf - I have defined it in every section and it still doesn't seem to work.

[main]
    # The Puppet log directory.
    # The default value is '$vardir/log'.
    logdir = /var/log/puppet

    # Where Puppet PID files are kept.
    # The default value is '$vardir/run'.
    rundir = /var/run/puppet

    # Where SSL certificates are kept.
    # The default value is '$confdir/ssl'.
    ssldir = $vardir/ssl

    server=lepus
    environmentpath = $confdir/environments
    basemodulepath = $confdir/modules:/usr/share/puppet/modules

[agent]
    # The file in which puppetd stores a list of the classes
    # associated with the retrieved configuratiion.  Can be loaded in
    # the separate ``puppet`` executable using the ``--loadclasses``
    # option.
    # The default value is '$confdir/classes.txt'.
    classfile = $vardir/classes.txt

    # Where puppetd caches the local configuration.  An
    # extension indicating the cache format is added automatically.
    # The default value is '$confdir/localconfig'.
    localconfig = $vardir/localconfig

    environment = production
    basemodulepath = $confdir/modules:/usr/share/puppet/modules

[master]
    environment = production
    manifest = $confdir/environments/$environment/manifests/site.pp
    modulepath = $confdir/environments/$environment/modules:$confdir/environments/$environment/site:$confdir/environments/$environment/dist
    basemodulepath = $confdir/modules:/usr/share/puppet/modules

[production]
    manifest = $confdir/environments/$environment/manifests/site.pp
    basemodulepath = $confdir/modules:/usr/share/puppet/modules
    modulepath = $confdir/environments/$environment/modules:$confdir/environments/$environment/site:$confdir/environments/$environment/dist

Am I doing something wrong, or am I missing something? I know there are ways around this - I could just append the basemodulepath to the end of modulepath - but I'd like to follow best practices and would like to know if this should work. I should also mention that I'm relatively new to Puppet so I may be missing something basic - I say this just so you don't assume that I have done everything else correct.

Thanks.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-02-07 13:25:10 -0500

GregLarkin gravatar image

Your documentation link above points to version 3.6, and directory environments were added to Puppet in version 3.5, not 3.3, so that's why the basemodulepath keyword is not working with Puppet 3.4.x available from the Pidora updates repository. You'll have to either wait for another update from the Pidora repository or roll your own RPM with an updated version of Puppet in order to do what you want.

Here is the reference to the release notes where directory environments are first mentioned: https://docs.puppetlabs.com/puppet/3.5/reference/release_notes.html#directory-environments

Hope that helps!

edit flag offensive delete link more

Comments

Thank you so much for the answer to my question. It was bothering me that I couldn't get it working.

racecarpassenger32 gravatar imageracecarpassenger32 ( 2015-02-12 20:06:22 -0500 )edit

Glad to help - cheers!

GregLarkin gravatar imageGregLarkin ( 2015-02-13 11:56:37 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-01-30 12:28:46 -0500

Seen: 204 times

Last updated: Feb 07 '15