Puppet agents do not report to Puppet-Dashboard

asked 2015-02-04 08:17:50 -0600

Konstantin Boyanov gravatar image

updated 2015-02-06 04:38:24 -0600

Hello Puppeteers!

I have the following problem:

Recently I set up a puppet-dashboard server (running on a different machine than the master) and everything seems to be running fine except the fact that I have to manually trigger the puppet agent runs on the corresponding machines, in order for them to send their reports to the puppet master.

What is so different between the "normal" scheduled puppet deamon run (no cronjob) and the manual puppet run with:

puppet agent -t

How can I configure the agent so they send their reports also automatically to the master / dashboard server?

EDIT: I use puppet 2.6.8 installed as rubygems (master and agents) on a SLES 11 SP0-SP3 platform. Ruby is ruby 1.8.7 (2008-08-11 patchlevel 72)

Thanks in advance! Regards, Konstantin Boyanov

edit retag flag offensive close merge delete

Comments

what is a value of reporturl = XXX in [master]?

confiq gravatar imageconfiq ( 2015-02-04 08:36:26 -0600 )edit

It is the following: reporturl = http://puppet.mydomain.com/reports/upload

Konstantin Boyanov gravatar imageKonstantin Boyanov ( 2015-02-04 08:44:41 -0600 )edit

and `reports = http` ?

confiq gravatar imageconfiq ( 2015-02-04 08:46:53 -0600 )edit

Yes, reports = store, http is set

Konstantin Boyanov gravatar imageKonstantin Boyanov ( 2015-02-04 08:48:56 -0600 )edit

and clients have `report = true` This should work, check logs...

confiq gravatar imageconfiq ( 2015-02-04 10:07:04 -0600 )edit