Ask Your Question
1

Deafult login for Puppet Enterprise Console Learning VM

asked 2015-02-16 16:33:01 -0500

igoros777 gravatar image

After downloading ( http://puppetlabs.com/download-learni... ) and installing the "Learning Puppet VM", it is rejecting the default login for the Puppet Enterprise Console listed in the documentation ( https://docs.puppetlabs.com/learning/... ): "To view the Puppet Enterprise web console, navigate to https://(your VM's IP address) in your web browser. Log in as puppet@example.com , with the password learningpuppet."

Any ideas what the correct login credentials might be?

edit retag flag offensive close merge delete

7 Answers

Sort by ยป oldest newest most voted
1

answered 2015-06-30 09:00:33 -0500

ChristopherDrews gravatar image

I use admin and learningpuppet and I still fail to login!

log file say: 2015-06-30 15:12:48,640 WARN [p.r.utils] Authentication failed.

Pls help

edit flag offensive delete link more
1

answered 2015-08-19 21:05:03 -0500

Kishore gravatar image

i used 'admin' and 'puppetlabs' as ID and password, it works.

edit flag offensive delete link more

Comments

It works... partially You are not authorized to access the console.

garfius gravatar imagegarfius ( 2016-03-17 04:04:26 -0500 )edit

6 answers and only this one works, me being the first one to vote it. I guess that the community is not so big.

sbarnea gravatar imagesbarnea ( 2016-07-17 15:03:45 -0500 )edit
0

answered 2016-02-20 18:24:07 -0500

press0 gravatar image

Hi Greg, [one year later] admin / learningpuppet works, but the enterprise console throws the error in the attached screenshot.

And the error in the browser is : An error occurred loading this page: There was an error connecting to PuppetDB: java.net.ConnectException: Connection refused

please advise.

C:\fakepath\puppet1.png

edit flag offensive delete link more
0

answered 2015-02-18 13:36:21 -0500

GregLarkin gravatar image

There is an error on the web page that shows the login credentials. Please use the username admin with password learningpuppet to log into the PE web console.

I have filed a ticket with our education team, and I hope the public web page will be updated with the correct username very shortly.

edit flag offensive delete link more
0

answered 2016-10-16 17:14:28 -0500

ldco2016 gravatar image

Yeah none of these answers are it. I don't even remember providing a username and password when I installed Puppet on my server. Anybody have the correct answer?

edit flag offensive delete link more
0

answered 2016-07-18 01:41:33 -0500

slee gravatar image

None of the passwords mentioned worked.

I'm clicking on the icon "Practice VM 2.30 r2" in the learning centre and current doing the "Class" module. It was working for me and then all the sudden I now require a password.

I don't believe something like this is so complicated. It should just work by clicking on this icon or a clear instruction on exactly what I need to do. The security icon also has this message "No credentials are available for this VM".

Thanks.

edit flag offensive delete link more
0

answered 2016-03-17 04:03:27 -0500

garfius gravatar image

The username/password combination entered is incorrect. If you believe you have received this message in error, please consult the logs at /var/log/puppetlabs/console-services/console-services.log.

Need help too

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-02-16 16:33:01 -0500

Seen: 4,604 times

Last updated: Jul 18 '16