Ask Your Question
0

Puppet Upgrade 3.3.2 to 3.7.2 - Not fetching catalogs anymore

asked 2015-02-25 01:48:51 -0500

DanielG gravatar image

updated 2015-02-25 11:01:50 -0500

GregLarkin gravatar image

Hi there,

I am still a puppet newbie trying to use puppet. So I updated the puppet-master in a quite small dev environment form 3.3.2 to 3.7.2. But now I have the problem that when I try to run puppet agent on the server via:

puppet agent -t

I get the following error:

Error: Could not retrieve catalog from remote server: Error 400 on SERVER: Could not find class pe_puppetdb::master::config for ixx on node ixx
Warning: Not using cache on failed catalog
Error: Could not retrieve catalog; skipping run

On the two nodes i get:

Could not retrieve catalog from remote server: Error 400 on SERVER: Could not find class pe_mcollective for ioo on node ioo
Could not retrieve catalog; skipping run

So somehow it isn´t possible to get the catalog. I already checked this page: https://docs.puppetlabs.com/pe/latest...

The puppet-master is reachable, I also can enter the puppet-console and the nodes a certificated. I don´t know for sure if the ssl is working right or if this could be the error. In the directory /opt/puppet/sbin/ there is a puppetdb and a mcollectived. And while updating I couldn´t find any error. As I said initially I am still a newbie maybe there is a simple solution which I just oversee or forgot something during the upgrade.

Would be awesome if anyone could help me! Thanks in advance!

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2015-02-25 11:04:34 -0500

GregLarkin gravatar image

Did you follow the post-upgrade instructions, particularly the manual configuration of certain node classifier groups found here: https://docs.puppetlabs.com/pe/latest/installupgradingnotes.html#classifying-pe-groups?

Please check if your node groups have all of the correct classes assigned to them, as detailed on that page. If they do and you still see errors, please post back here.

edit flag offensive delete link more

Comments

Thank you very much. Somehow haven´t seen that there is a classification necessary, after that the run works again, but now I have another problem the nodes and the master are unresponsive at puppet enterprise console.

DanielG gravatar imageDanielG ( 2015-02-26 04:04:52 -0500 )edit

Can you run "puppet agent -t" on the master or any nodes without any errors? After you do that, do you see any reports from them in the PE console?

GregLarkin gravatar imageGregLarkin ( 2015-02-26 15:15:17 -0500 )edit

Yes, on the master I can run "puppet agent -t": Info: Applying configuration version '1424942335' Notice: Finished catalog run in 0.28 seconds But the console still is in unresponsive, in the PE Infrastructure Node Group, I put database_ssl true, and the ports the variables automatically filled by

DanielG gravatar imageDanielG ( 2015-02-27 01:11:58 -0500 )edit

PE-Console like $puppet_enterprise::params::database_port. I am not sure about the postgresql but everything is set like mentioned here: https://docs.puppetlabs.com/pe/3.7/install_ssl_postgresql.html. I don´t have set the reporturl in puppet.conf or an external_node in puppet_dashboard.

DanielG gravatar imageDanielG ( 2015-02-27 01:49:03 -0500 )edit

Is this necessary? Thank you very much for helping me, that´s awesome!

DanielG gravatar imageDanielG ( 2015-02-27 01:50:16 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-02-25 01:48:51 -0500

Seen: 194 times

Last updated: Feb 25 '15