Ask Your Question
0

opendkim-genkey: openssl exited with status %d

asked 2013-06-10 14:01:12 -0500

greywindow gravatar image

Hello, I'm trying to create new module for opendkim module on puppet-2.7.10-1.el5.noarch and the process almost works.

info: Caching catalog for ipek.ec2.internal
info: Applying configuration version '1370890364'
notice: /Stage[main]/Opendkim::Config/File[/etc/opendkim]/ensure: created
notice: /Stage[main]/Opendkim::Config/File[/etc/opendkim/TrustedHosts]/ensure: defined content as '{md5}1ff6bb5cce33f7d8b989291c222d88f4'
notice: /Stage[main]/Opendkim::Config/File[/etc/opendkim/KeyTable]/ensure: defined content as '{md5}38922388ad6b841f3836f2a02ab566fa'
notice: /Stage[main]/Opendkim::Config/File[/var/run/opendkim]/ensure: created
notice: /Stage[main]/Opendkim::Config/File[/etc/opendkim/opendkim.conf]/ensure: defined content as '{md5 ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-06-11 09:58:44 -0500

greywindow gravatar image

OK, I've found the solution. 127 is for command not found and I thought these lines:

notice: /Stage[main]/Opendkim::Commands/Exec[generate-keys]/returns: opendkim-genkey: openssl exited with status %d
notice: /Stage[main]/Opendkim::Commands/Exec[generate-keys]/returns: 127

complains about opendkim-genkey but in fact this error is for openssl and openssl is in /usr/bin so simply: make sure your path is like this:

path => ["/usr/sbin/", "/usr/bin"],

I thought I would add it just in case.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-06-10 14:01:12 -0500

Seen: 808 times

Last updated: Jun 11 '13