Ask Your Question
0

Setting "enabled = true" on yumrepo does not enable it. Why?

asked 2015-03-06 03:59:05 -0600

Krist van Besien gravatar image

I am doing the following in a manifest:

yumrepo { 'epel-6-x86_64':
    enabled     => '1',
    includepkgs => 'python-gevent python-pip librabbitmq python-meld3'
}

When I subsequently look in /etc/yum.repos.d/redhat.repo I see that in the [epel-g-x86_64] section the "includepkgs" parameter has been added, but enabled has not been changed to 1.

When I run puppet I get the following output:

Notice: /Stage[main]/Contrail/Yumrepo[epel-6-x86_64]/enabled: enabled changed ' 0' to '1'
Notice: /Stage[main]/Contrail/Yumrepo[epel-6-x86_64]/includepkgs: includepkgs changed ' ' to 'python-gevent python-pip librabbitmq python-meld3'

Why is the module claiming that it set enabled to 1, but fails to actually do so?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-03-06 11:20:04 -0600

Krist van Besien gravatar image

The answer was simple: On Red Hat 7 yumrepo does not work. What yumrepo does is manipulate the content of the files under /etc/yum.repos.d. On Red Hat 7 these files get managed by subscription-manager, and edits can (and do) get overwritten.

So the "provider" for Red Hat for this type might need to be rewritten to use subscription-manager.

edit flag offensive delete link more

Comments

Krist, can you submit a ticket at https://tickets.puppetlabs.com/browse/PUP describing the issue and any debug information you can provide?

rnelson0 gravatar imagernelson0 ( 2015-03-13 22:30:57 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-03-06 03:59:05 -0600

Seen: 159 times

Last updated: Mar 06 '15