puppetlabs-splunk error

asked 2015-03-06 10:15:17 -0500

qwerty_face gravatar image

updated 2015-03-06 10:16:04 -0500

I am running the puppetlabs-splunk module to install the forwarder module. As per the module instructions I have populated the specific RPM file I am trying to install as per the directory structure suggested by the doc for the module (i.e. have created the folder "universalforwarder" with subdirectory "linux" containing the splunkforwarder RPM underneath the modules "files" directory).

When I run the agent on the puppet agent the file is successfully staged/cached and is created on the puppet agent node under the "/opt/staging/splunk" directory where the RPM has been transferred. Immediately hereafter the puppet agent error's out. It seems to me that the puppet agent is failing to install the RPM. Here is the output (where it begins to fail - I have truncated since I have this on puppet agent -t --debug):

Notice: /Stage[main]/Splunk::Forwarder/Staging::File[splunkforwarder-6.2.2-255606-linux-2.6-x8664.rpm]/File[/opt/staging/splunk/splunkforwarder-6.2.2-255606-linux-2.6-x8664.rpm]/ensure: defined content as '{md5}4086c3525ad5a2fc277bc4a4e677a428' Debug: /Stage[main]/Splunk::Forwarder/Staging::File[splunkforwarder-6.2.2-255606-linux-2.6-x8664.rpm]/File[/opt/staging/splunk/splunkforwarder-6.2.2-255606-linux-2.6-x8664.rpm]: The container Staging::File[splunkforwarder-6.2.2-255606-linux-2.6-x8664.rpm] will propagate my refresh event Debug: Staging::File[splunkforwarder-6.2.2-255606-linux-2.6-x8664.rpm]: The container Class[Splunk::Forwarder] will propagate my refresh event Debug: Prefetching rpm resources for package Debug: Executing '/bin/rpm --version' Debug: Executing '/bin/rpm -qa --nosignature --nodigest --qf '%{NAME} %|EPOCH?{%{EPOCH}}:{0}| %{VERSION} %{RELEASE} %{ARCH}\n'' Error: Could not set 'present' on ensure: No such file or directory - /opt/splunkforwarder/etc/system/local/outputs.conf at 91:/mnt/hgfs/vm_shared/puppet/forge-modules/splunk/manifests/forwarder.pp

Any ideas on this?

NOTE: have posted this here since this module is a puppetlabs authored module...

edit retag flag offensive close merge delete

Comments

Can you post a link to a pastebin that includes all of your relevant Puppet code? It will be easier to troubleshoot if someone can apply your exact code to a test machine and try to reproduce the issue.

GregLarkin gravatar imageGregLarkin ( 2015-03-06 10:22:57 -0500 )edit

The only two non-default statements I've added to the agent node's `puppet.conf` file is `server = <server>`, and `environment = TEST`. On the master side I have a folder called `TEST` under `/etc/puppet/manifests` with a puppet node class of `panda.localdomain.pp`.

qwerty_face gravatar imageqwerty_face ( 2015-03-06 10:29:33 -0500 )edit

Ok, so can you post a link to a pastebin of your panda.localdomain.pp file somewhere? It would help greatly to be able to see the source code.

GregLarkin gravatar imageGregLarkin ( 2015-03-06 12:31:48 -0500 )edit

Yes. Here's the panda.localdomain.pp file: http://pastebin.com/0icPPaWB. Here's the role for that node: http://pastebin.com/gdxfx1Sr. Here's the profile for that role: http://pastebin.com/PSyST3Pb. Here's the other profile that applies the box config: http://pastebin.com/0sMZRzKR . Also...

qwerty_face gravatar imageqwerty_face ( 2015-03-08 14:59:05 -0500 )edit

I have added a "universalforwarder" directory under "files" of the puppetlabs-splunk module folder, with a "linux" subdirectory that contains the splunkforwarder rpm. The specific version I have is 6.2.2 of build 255606. I have changed the values of the appropriate variables in param.pp.

qwerty_face gravatar imageqwerty_face ( 2015-03-08 15:01:54 -0500 )edit