Ask Your Question
1

Is puppet-dashboard compatible with Ubuntu 14.04 64bit?

asked 2015-03-10 08:55:54 -0500

Adam Ryczkowski gravatar image

updated 2015-03-10 08:56:10 -0500

The package puppet-dashboard is missing. Just compare the Trusty's repository hosted by Puppetlabs: https://apt.puppetlabs.com/pool/trust... with e.g. good old Precise's: https://apt.puppetlabs.com/pool/preci...

Puppetlabs' own puppet module that manages its installation seems to never been actually tested on Trusty, starting with wrong location for the nologin binary (which on Debian-based system is /usr/sbin/nologin rather than /sbin/nologin). I started to slowly cut my way through it, but after spending half of day and workarounding the mentioned two issues and some other I realized that it would take at least 2 days to work out how to install it (and make a working puppet module). I know almost exactly no Ruby, so if there is a deeper problem with the dashboard code itself, all this time would be simply wasted.

Did anyone managed to run it on Ubuntu 14.04?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2015-03-10 14:30:45 -0500

ramindk gravatar image

The Puppetlabs version of puppet-dashboard requires Ruby 1.8.7. 14.04 ships with 1.9.3. Also it was EOL'ed Oct 2012.

There has been some community updates to the original dashboard. You may want to look at Foreman or puppetboard as well.

edit flag offensive delete link more

Comments

I didn't know it was depreciated! Thanks a lot for the info.

Adam Ryczkowski gravatar imageAdam Ryczkowski ( 2015-03-10 15:02:48 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-03-10 08:55:54 -0500

Seen: 1,243 times

Last updated: Mar 10 '15