Ask Your Question
0

puppet master does not listen on port 8140

asked 2015-03-12 03:22:45 -0500

jdhvnkl2 gravatar image

Hi

I have installed puppet master on red hat 6. however when I run telnet <puppet-master-name> 8140, Connection refuse. I already tried to do iptables and i am trying to do the telnet from the puppet master itself. when i run the command puppet agent --test the following error occurred: Connecction refused - connect (2) for "<puppetmaster name="">" port 8140. it is standalone network which mean you need to think of this as "offline" machine.

thank you

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2015-03-13 05:42:47 -0500

can you telnet to any port on that machine?

lsof -i:8140 is puppet master running which is obvious question (ps -ef|grep puppet) try telneting to one of the other open ports (e.g. telnet localhost 25)

is puppetmaster name also in /etc/hosts ?

Cheers Stuart

edit flag offensive delete link more
0

answered 2015-03-17 07:09:16 -0500

Kabelo gravatar image
  1. Check if you have port 8140 listening on your Master.
  2. Stop your Iptables
  3. Make sure you have masterport=8140 on the Agent config(etc/puppet/puppet.config)
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-03-12 03:22:45 -0500

Seen: 7,217 times

Last updated: Mar 13 '15