Ask Your Question
0

Solaris 9 and 3.7

asked 2015-03-19 10:51:20 -0500

TomSchenk gravatar image

I am looking to implement Puppet Enterprise 3.7.x in our environments, but am concerned about the compatability matrix that indicates that it is only supported on Solaris 10.9 ad later. We still have a few Solaris systems running versions prior to that.

I have heard a couple of different reasons why this version requirement exists, firstly that there is a dependency on Ruby that can't be satisfied on earlier versions of Solaris, or that there is actually some other dependency (such as a dependency on zone support in the OS kernel), but I can't find a definitive answer.

Not being able to support my older solaris nodes is a serious concern and I need to be able to run at least version 3.0 in order to implement what I need to implement.

does anyone know where I can find this asnwer?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-03-24 19:03:32 -0500

csharpsteen gravatar image

The list of operating systems for which Puppet Enterprise is available can be found on the System Requirements page. At the time of writing the list of supported Solaris versions is 10 update 9 and later.

The following JIRA ticket is used to track requests for adding operating systems to the list of platforms supported by Puppet Enterprise:

https://tickets.puppetlabs.com/browse/ENTERPRISE-18

The Open Source agent may be installable on Solaris 9 by using the gem package manager. However, Puppet 3.7.x is currently only acceptance tested against Solaris 10 and 11 so functionality on Solaris 9 may vary.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2015-03-19 10:51:20 -0500

Seen: 156 times

Last updated: Mar 24 '15