Could not run Puppet configuration client

asked 2015-03-23 01:27:02 -0500

tokiw gravatar image

Hi,

I'm trying to use the puppetlabs-apache module. I synced the various prerequisite plugins with --pluginsync, but now the client refuses to run with the following error:

$ puppet agent apply --test --environment=myenv --pluginsync info: Retrieving plugin err: Could not run Puppet configuration client: Could not retrieve local facts: undefined method `which' for Facter::Util::Resolution:Class

This is with Puppet master running version:

$ puppet --version 2.7.18

And client running version:

$ puppet --version 2.7.26

Any assistance would be appreciated.

Cheers, Toki

edit retag flag offensive close merge delete

Comments

Can you run the same command with a --trace to see what the offending file is? Thanks.

WhatsARanjit gravatar imageWhatsARanjit ( 2015-03-25 11:33:12 -0500 )edit

I encountered the same error. Puppet Master version 3.7.1. Puppet client 2.7.11. Trace gives: http://pastebin.com/iZthECNa A higher puppet version seems to work better. (i.e. some client nodes are on 3.6.2 and they don't exhibit this behaviour)

ianmac gravatar imageianmac ( 2015-03-31 10:40:24 -0500 )edit