Ask Your Question
0

Missing step in setting up a non-root agent

asked 2015-03-24 22:09:01 -0600

dimarra gravatar image

We are setting up PE Agents on Redhat using the steps indicated here https://docs.puppetlabs.com/pe/latest...

After step 5, the following folders are owned by root - /opt/puppet, /var/log/puppet, /etc/puppet. I dont see steps 6 through 10 correcting the file permissions, given that when you do the first puppet agent --test fails with permission issues on the said folders. There could be some steps missing during this transition from root to non-root user.

Did anybody experienced the same? How did you solve it? what am I missing? Thanks

edit retag flag offensive close merge delete

Comments

Can you share the error messages you observe, and any of the output for steps 1-10 that you may have saved or can recreate?

rnelson0 gravatar imagernelson0 ( 2015-03-25 20:28:14 -0600 )edit

I worked on my module as root to bypass this issue up until now. I have upload the output here. http://pastebin.com/CzCNYN5r thanks for your help

dimarra gravatar imagedimarra ( 2015-04-14 00:29:07 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-04-26 23:59:27 -0600

dimarra gravatar image

is anybody able to help? Thanks

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-03-24 22:09:01 -0600

Seen: 108 times

Last updated: Apr 26 '15