Ask Your Question
0

Will my 3.x Puppet master work with Passenger 5.x?

asked 2015-03-30 14:55:15 -0600

ramindk gravatar image

updated 2016-06-05 14:37:46 -0600

I noticed Passenger 5.0.5 has been released this week. Will it work it with Puppet?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2015-09-18 18:23:38 -0600

ramindk gravatar image

My test system:

  • Ubuntu 12.04 LTS
  • Puppet 3.7.5
  • Passenger 5.0.5
  • Apache 2.2.x

Once I installed I began receiving the following errors in the logs

Mar 30 19:48:21 puppet01 puppet-master[5908]: Denying access:  Forbidden request: fe01 access to /file_metadata/plugins [search] at :76
Mar 30 19:48:21 puppet01 puppet-master[5908]: Forbidden request: fe01 access to /file_metadata/plugins [search] at :76

Testing later with Passenger 5.0.18 and Puppet 3.8.2 worked just fine. Not sure which upgrade helped.

It appears that earlier Passenger versions worked fine on nginx.

edit flag offensive delete link more
0

answered 2015-04-01 02:45:43 -0600

kay gravatar image
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-03-30 14:55:15 -0600

Seen: 399 times

Last updated: Jun 05 '16