Ask Your Question
0

Puppet master caching?

asked 2015-04-28 15:03:32 -0500

arussell gravatar image

updated 2015-05-01 14:28:19 -0500

I am setting up a new Puppet 4 server. (we are currently running 2.6 on a different server)

In testing I am running puppet multiple times from a client with --noop.

First run works and displays what needs to be changed, then it acts like nothing needs to be changed on every run after that. If i restart puppet server it works for the first run again, then no changes.

I have ignorecache = true on the client but doesn't change anything.

Here is some output from the puppet master.

First Run Notice: Compiled catalog for puppet-test in environment production in 1.94 seconds Every run after Notice: Compiled catalog for puppet-test in environment production in 0.02 seconds

So it seems the server is caching something. I have tried to clear the cache via the API but no changes.

Edit: After some digging I found if I list the class in site.pp instead of using hiera_include function it works with no issues.

edit retag flag offensive close merge delete

Comments

In my case, I didnt get an updated catalog because I enabled Code Manager once you enable Code Manager to manage your puppet basemodulepath, even if you do direct manual changes to code on your /etc/puppetlabs/code path, Puppet doenst pick it up. Only way to update is to do a "puppet-code deploy"

mike.r gravatar imagemike.r ( 2016-08-25 11:46:10 -0500 )edit

4 Answers

Sort by ยป oldest newest most voted
2

answered 2015-05-03 10:26:18 -0500

camlow325 gravatar image

updated 2015-05-03 10:29:26 -0500

This issue sounds like PUP-4461. Until that fix is delivered in a release, you might try locally applying the changes documented in the linked PR to your local /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/pops/loaders.rb file. Also, this change has been committed to the latest master, stable, and 3.x branches in the puppet repository.

edit flag offensive delete link more

Comments

Thanks I noticed this shortly after I figured out it was hiera_include.

arussell gravatar imagearussell ( 2015-05-04 07:22:09 -0500 )edit
0

answered 2015-05-03 04:33:57 -0500

Marek Maksimczyk gravatar image

Do you try --test param in puppet agent cmd?

See more in https://docs.puppetlabs.com/reference...

edit flag offensive delete link more
0

answered 2015-04-29 08:19:21 -0500

This might be caused by the environment_timeout in your environment.conf.

Try setting environment_timeout to 0 (zero).

See https://docs.puppetlabs.com/puppet/la...fileenvironment.html#environmenttimeout

edit flag offensive delete link more

Comments

Thanks but no change. According to the docs https://docs.puppetlabs.com/puppet/latest/reference/environments_configuring.html#environmenttimeout It defaults to 0 already.

arussell gravatar imagearussell ( 2015-04-29 08:31:45 -0500 )edit
0

answered 2016-08-18 15:03:01 -0500

mike.r gravatar image

Im having the same issue with Puppet 4.5.2 Master on Ubu 14.04, agent on Centos7

heres the link to my issue, seems exact same problem

https://groups.google.com/forum/#!top...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-04-28 15:03:32 -0500

Seen: 1,181 times

Last updated: Aug 18 '16