Samba shares read-only

asked 2015-05-02 22:23:00 -0600

Rob D. gravatar image

updated 2015-05-02 22:23:25 -0600

I'm trying to "puppetize" my home server (ubuntu trusty + ZFS raidz2) and Samba shares are showing up read-only.

Here's the output of sudo smbstatus:

Samba version 4.1.6-Ubuntu
PID     Username      Group         Machine
-------------------------------------------------------------------
6050      user1           group1      192.168.x.y (ipv4:192.168.x.y:63671)

Service      pid     machine       Connected at
-------------------------------------------------------
user1          6050   192.168.x.y  Sun May  3 02:01:59 2015

Locked files:
Pid          Uid        DenyMode   Access      R/W        Oplock           SharePath   Name   Time
--------------------------------------------------------------------------------------------------
6050         9001       DENY_NONE  0x100081    RDONLY     NONE             /mnt/storage/user1   .   Sun May  3 02:02:01 2015
6050         9001       DENY_NONE  0x100081    RDONLY     NONE             /mnt/storage/user1   .   Sun May  3 02:02:01 2015

Here's my smb.comf:

# smb.conf
# Managed by Puppet - DO NOT EDIT BY HAND

[global]
  workgroup       = WORKGROUP
  netbios name    = %L
  security        = user
  server string   = Samba shares on %L
  max log size    = 1000
  include         = /etc/samba/include/smb.conf.*

And here's the contents of include/smb.conf.user1.erb:

# smb.<%= @user1name %>.conf.erb
# Managed by Puppet - DO NOT EDIT BY HAND

[<%= @user1name %>]
  workgroup      = WORKGROUP
  path           = <%= @user1home %>
  browseable     = yes
  read only      = no
  create mask    = 0644
  directory mask = 0755
  force user     = <%= @user1name %>
  force group    = <%= @user1group %>
  valid users    = <%= @user1name %>
  comment        = Home folder for <%= @user1name %> (Samba %v on %L)

Help?

edit retag flag offensive close merge delete

Comments

Please post a link to a pastebin of all of your Puppet code as well, and that should help with troubleshooting.

GregLarkin gravatar imageGregLarkin ( 2015-05-04 19:52:03 -0600 )edit