Ask Your Question
0

Connection timed out at `puppet module install`

asked 2015-05-08 06:49:18 -0500

Jimmy Chu gravatar image

updated 2015-05-11 23:02:58 -0500

Hi,

I am trying to install a puppet module, and it gives me connection timeout

root@oo5:/var/log/httpd# puppet module install --verbose --debug openshift/openshift_origin
Debug: Runtime environment: run_mode=user, ruby_version=1.8.7, puppet_version=3.7.5
Notice: Preparing to install into /etc/puppet/modules ...
Notice: Downloading from https://forgeapi.puppetlabs.com ...
Debug: HTTP GET https://forgeapi.puppetlabs.com/v3/releases?module=openshift-openshift_origin
Debug: Failed to load library 'pe_license' for feature 'pe_license'
Error: Could not connect to https://forgeapi.puppetlabs.com
  There was a network communications problem
    The error we caught said 'Connection timed out - connect(2)'
    Check your network connection and try again

I google searched a bit and the solutions are mostly related to http proxy setting which I am not using.

But when I run the command in my VM it properly installed the module.

root@oo1:/etc# puppet module install openshift/openshift_origin --debug
Debug: Runtime environment: ruby_version=1.8.7, puppet_version=3.7.5, run_mode=user
Notice: Preparing to install into /etc/puppet/modules ...
Notice: Downloading from https://forgeapi.puppetlabs.com ...
Debug: HTTP GET https://forgeapi.puppetlabs.com/v3/releases?module=openshift-openshift_origin
Debug: Failed to load library 'pe_license' for feature 'pe_license'
Debug: HTTP GET https://forgeapi.puppetlabs.com/v3/releases?module=openshift-openshift_origin&limit=20&offset=20
Debug: Failed to load library 'pe_license' for feature 'pe_license'
...
Info: Resolving dependencies ...
Info: Preparing to install ...
Debug: HTTP GET https://forgeapi.puppetlabs.com/v3/files/openshift-openshift_origin-4.1.2.tar.gz
Debug: Failed to load library 'pe_license' for feature 'pe_license'
Debug: Executing 'gzip -dc /var/lib/puppet/puppet-module/cache/openshift-openshift_origin20150508-5207-1d47sws-0 | tar xof -'
Debug: Executing 'find . -type d -exec chmod 755 {} +'
Debug: Executing 'find . -type f -exec chmod a-wst {} +'
Debug: Executing 'chown -R 0:0 .'
Notice: Installing -- do not interrupt ...
/etc/puppet/modules
└─┬ openshift-openshift_origin (v4.1.2)
  ├── arioch-keepalived (v1.1.1)
  ├── blentz-selinux_types (v0.1.0)
  ├── duritong-sysctl (v0.0.8)
  ├── puppetlabs-haproxy (v1.2.0)
  ├── puppetlabs-java_ks (v1.3.0)
  ├── puppetlabs-ntp (v3.3.0)
  ├── puppetlabs-stdlib (v4.6.0)
  └── rharrison-lokkit (v0.5.0)

So albeit of the warning message, it could be a system configuration that is fixable on my side. I appreciate if anybody could shed me some light on how to fix this issue.

Thank you.

[Update 2015/05/12]

Output of running relevant commands:

root@oo5:~# host forgeapi.puppetlabs.com
forgeapi.puppetlabs.com is an alias for forge-api-fr.puppetlabs.com.
forge-api-fr.puppetlabs.com has address 23.236.57.230

root@oo5:~# ping -w 1 -c 1 forgeapi.puppetlabs.com 
PING forge-api-fr.puppetlabs.com (23.236.57.230) 56(84) bytes of data.
64 bytes from 230.57.236.23.bc.googleusercontent.com (23.236.57.230): icmp_seq=1 ttl=48 time=197 ms

--- forge-api-fr.puppetlabs.com ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 198ms
rtt min/avg/max/mdev = 197.616/197.616/197.616/0.000 ms

root@oo5:~# traceroute forgeapi.puppetlabs.com
traceroute to forgeapi.puppetlabs.com (23.236.57.230), 30 hops max, 60 byte packets
 ...
 4  p15169.sgw.equinix.com (202.79 ...
(more)
edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
1

answered 2015-05-08 10:35:32 -0500

iptables active on the failed node? what does a traceroute to forgeapi.puppetlabs.com show?

edit flag offensive delete link more

Comments

Thank for the hint. Please refer to update.

Jimmy Chu gravatar imageJimmy Chu ( 2015-05-11 23:03:37 -0500 )edit
1

answered 2015-05-08 10:35:31 -0500

JohnsonEarls gravatar image

updated 2015-05-11 23:50:37 -0500

This looks like a network or routing problem on your host. a couple of things to try on oo5:

host forgeapi.puppetlabs.com
ping -w 1 -c 1 forgeapi.puppetlabs.com 
traceroute forgeapi.puppetlabs.com

More stuff to check: Do either or both of the following commands work on oo5?

wget -v -O /dev/null "http://forgeapi.puppetlabs.com/v3/releases?module=openshift-openshift_origin"
wget --no-check-certificate -v -O /dev/null \
    "https://forgeapi.puppetlabs.com/v3/releases?module=openshift-openshift_origin"
edit flag offensive delete link more

Comments

Thank for the note. Please refer to update.

Jimmy Chu gravatar imageJimmy Chu ( 2015-05-11 23:03:47 -0500 )edit

@JohnsonEaris, thanks. I have since switched to another cloud service provider and the problem disappears. Before I give up solving the problem, I particularly set the `iptables` to allow https connection. But `curl -L https://forgeapi.puppetlabs.com` just doesn't connect.

Jimmy Chu gravatar imageJimmy Chu ( 2015-05-12 20:52:46 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2015-05-08 06:49:18 -0500

Seen: 910 times

Last updated: May 11 '15