Ask Your Question
0

puppetlabs-mysql -- Setting package_manage & service_manage to false doesn't work?

asked 2015-05-08 18:05:32 -0500

updated 2015-05-08 18:26:09 -0500

I'd like to use the puppetlabs-mysql module, but I want to manage the package and the service outside of this module. I'm using the mysql-community-* packages from https://repo.mysql.com/yum/mysql-comm... , and managing these outside of the puppetlabs-mysql module seems simpler.

So, I thought I could tell puppetlabs-mysql to ignore the MySQL package and service with this exampele manifest:

class { '::mysql::server':         
  package_manage => false,
  service_manage => false,
}

But that doesn't seem to work, and Puppet complains about Package[mysql-server] and Service[mysqld]:

[root@db1 ~]# puppet agent --test --noop
Info: Retrieving pluginfacts
Info: Retrieving plugin
Info: Loading facts
Info: Loading facts
Info: Caching catalog for db1.example.org
Error: Failed to apply catalog: Could not find dependency Package[mysql-server] for Service[mysqld] at .../modules/mysql/manifests/server/service.pp:25
[root@db1 ~]#

If I set package_manage and service_manage to false, shouldn't that disable this warning?

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2015-05-08 19:21:06 -0500

JohnsonEarls gravatar image

This looks like a bug in the puppetlabs-mysql module. In mysql::server::service, it defines the mysqld service and sets up the dependency without checking if the service is being managed.

I've submitted bug MODULES-2030 for this, and submitted a patch to the devs.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2015-05-08 18:05:32 -0500

Seen: 365 times

Last updated: May 08 '15