Ask Your Question

puppetserver 2 times out because it cannot find a key

asked 2015-05-09 02:00:47 -0600

chriscowley gravatar image

Fresh install on Centos (tried both 6 and 7) from the PC1 repo. Starting puppetserver munchs away at my RAM for a few minutes then fails with this error:

Exception in thread "main" java.lang.IllegalStateException: Cannot initialize master with partial state; need all files or none.

It seems that it is looking in the wrong directory for the public key as it appears to have been created elsewhere:

[chris@puppet ~]$ sudo find /etc/puppetlabs/ -name puppet.novalocal.pem

I am dumbly following the official docs. so it may mean a little correction there or in the install package

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2015-05-09 09:28:40 -0600

JohnsonEarls gravatar image

updated 2015-12-03 07:10:38 -0600

This is caused by running the puppet agent before running the puppet server. Please see issue SERVER-528 in the puppetlabs ticketing system for details. Easiest thing to do is remove the contents of the /etc/puppetlabs/puppet/ssl directory before starting the server for the first time.

edit flag offensive delete link more



That was it. To be really picky, do not remove the ssl directory itself. You need to remove the *contents* of that directory. If not, the puppet agent run that occurs during the server bootup (which seems to run as the _puppet_ user) cannot re-create the `ssl` directory.

chriscowley gravatar imagechriscowley ( 2015-05-09 14:21:29 -0600 )edit

Okay. I thought that starting the puppetserver process will create the /etc/puppetlabs/puppet/ssl directory, but maybe not.

JohnsonEarls gravatar imageJohnsonEarls ( 2015-05-10 17:20:12 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2015-05-09 02:00:47 -0600

Seen: 930 times

Last updated: Dec 03 '15