Ask Your Question
0

Client Connection Failure

asked 2015-05-18 12:08:43 -0600

Mike Cataldo gravatar image

After a successful installation of Puppet Enterprise on Ubuntu 14.04 I cannot connect clients to the puppet master. I have no firewall in place and a simple "telnet hostname 8140" fails. I assumed after the puppet enterprise install completed it would be listening on the appropriate port. Am I missing something?

edit retag flag offensive close merge delete

Comments

Hi, did you sign the certificates of your agents? you can do it via puppet-enterprise-console or commandline: puppet cert list --all (should show you if there are any requests) puppet cert sign nodename https://docs.puppetlabs.com/pe/latest/install_agents.html#signing-agent-certificates

DanielG gravatar imageDanielG ( 2015-05-20 07:13:49 -0600 )edit

I haven't done anything on the client because of the failed installation. The master installed without issue and I was trying to install the client using the https://<master hostname="">:8140/packages/current

Mike Cataldo gravatar imageMike Cataldo ( 2015-05-27 11:46:50 -0600 )edit

5 Answers

Sort by ยป oldest newest most voted
0

answered 2015-05-28 14:59:30 -0600

Mike Cataldo gravatar image

The problem appears to be caused by the combination of packages installed on the server where I was attempting to install PE (master). We are building a new Linux environment and during this R & D period I was attempting to minimize the number of servers. While doing this I installed PE on a server running LDAP and DNS. With each attempt to install PE it resulted in the same error, unable to connect on port 8140.

I installed PE (monolithic install) on a stand-alone server and the installation completed with full verification and no errors. Now I'm moving on to the client agents which hopefully should connect on port 8140 for the agent installation.

I'm not exactly sure what caused the error but it definitely went away on a new stand-alone server. I don't see any documentation that suggests LDAP or DNS leverages port 8140.

edit flag offensive delete link more
0

answered 2015-05-22 03:53:23 -0600

rishibansal02 gravatar image

yes, first check if the port is conencting 8140. After that you can try to clear certificates as below. On puppet master: puppet cert clean <client hostname=""> On client: rm /etc/puppetlabs/puppet/ssl/certs/<client hostname="">.pem /etc/puppetlabs/puppet/ssl/publickeys/<client hostname="">.pem /etc/puppetlabs/puppet/ssl/certificaterequests/<client hostname="">.pem /etc/puppetlabs/puppet/ssl/private_keys/<client hostname="">.pem

After this re send the request from client: /opt/puppet/bin/puppet certificate find <puppet-master> --ca-location remote --ca_server <puppet-master>

List the pending cert req: puppet cert list

On puppet-master, accept the certificate: puppet cert --sign <client hostname="" as="" shown="" in="" cert="" list="">

edit flag offensive delete link more
0

answered 2015-05-27 22:42:44 -0600

Tawha gravatar image

Have you checked your iptables? Those should b off . try that first. If that does'nt work, we will go for further details then.

edit flag offensive delete link more
0

answered 2015-05-21 16:17:20 -0600

Hypnoz gravatar image

updated 2015-05-21 16:17:55 -0600

On the puppet master run some commands to see if the server is listening on that port.

netstat -ln | grep 8104
lsof -i :8140
ps axf | grep apache
telnet localhost 8140
curl http://localhost:8140

look at your apache configs and make sure apache is set up to actually listen on 8140 for that VirtalHost (ie: it has some lines like this in there:

Listen 8140
<VirtualHost *:8140>

This is all for regular puppet, I've never used puppet enterprise so your settings may be different. You should also have official support with PE correct?

edit flag offensive delete link more

Comments

Should apache be installed first? I assumed the PE installer would install any necessary additional packages.

Mike Cataldo gravatar imageMike Cataldo ( 2015-05-27 12:44:14 -0600 )edit

I was able to run the master installer on port 3000, does that not use apache?

Mike Cataldo gravatar imageMike Cataldo ( 2015-05-27 12:48:40 -0600 )edit

I started with a fresh Ubuntu install and attempted to install apache before installing the puppet master. I made sure port 8140 was mapped and running. When I attempted the master install it stated port 8140 was in use.

Mike Cataldo gravatar imageMike Cataldo ( 2015-05-27 14:30:28 -0600 )edit

During the master install process it attempts to connect to several different ports. The installer was able to connect to ports 8081, 443, 61613, 5432 but NOT 8140?

Mike Cataldo gravatar imageMike Cataldo ( 2015-05-27 14:31:46 -0600 )edit
0

answered 2015-05-28 00:40:40 -0600

I see you've said that on a fresh install, port 8140 was already in use. So what does netstat -ntlp tell you about what is using port 8140?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-05-18 12:08:43 -0600

Seen: 1,166 times

Last updated: May 28 '15