Ask Your Question
1

puppet-community/puppet-nodejs

asked 2015-05-18 12:10:23 -0600

slk gravatar image

updated 2015-05-18 12:11:12 -0600

I'm trying to implement puppet-community/puppet-nodejs

and getting the following error.

Error: Unknown function contain at /tmp/vagrant-puppet/modules-5cc0246577ab90ac47632078bb2d204a/nodejs/manifests/repo/nodesource.pp:86 on node puppet-vagrant

running puppet 3.3.2

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-05-18 17:25:29 -0600

GregLarkin gravatar image

The module author dropped support for Puppet < 3.4.0 fairly recently, so you'll either have to use an older version of the module or upgrade to a newer version of Puppet: https://github.com/puppet-community/puppet-nodejs/pull/121#issuecomment-89961883

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-05-18 12:10:23 -0600

Seen: 266 times

Last updated: May 18 '15