Ask Your Question
0

"mco puppet runonce" has one minute response delay

asked 2015-05-19 01:37:23 -0500

peier0810 gravatar image

updated 2015-05-20 02:52:27 -0500

Hi ,all

i run "mco puppet runonc -v" on the client,it can trigger the puppet agent successfully.but puppet agent will wait a minute after sending the first request to puppet master. here is the log of nginx at puppet master: image description

there is no error in puppet and mco 's log.

if i run "puppet agent -t -v" at puppet agent node directly,it has no delay. here is the log: image description

i review the report of the node ,the runtime is normal. in addition,just some of the nodes have the problem above . can anyone give me some sugesstions? many thanks.


PLUS

i'm not using Puppet Enterprise. here is the detail of puppet.conf on agent node: [main] # The Puppet log directory. # The default value is '$vardir/log'. logdir = /var/log/puppet

# Where Puppet PID files are kept.
# The default value is '$vardir/run'.
rundir = /var/run/puppet

# Where SSL certificates are kept.
# The default value is '$confdir/ssl'.
ssldir = $vardir/ssl
server = puppetmaster.glodon.com

[agent] # The file in which puppetd stores a list of the classes # associated with the retrieved configuratiion. Can be loaded in # the separate puppet executable using the --loadclasses # option. # The default value is '$confdir/classes.txt'. classfile = $vardir/classes.txt

# Where puppetd caches the local configuration.  An
# extension indicating the cache format is added automatically.
# The default value is '$confdir/localconfig'.
localconfig = $vardir/localconfig
environment= test
pluginsync = false
listen = true

it seems that there is no config about 'splay '. i tried the command "mco puppet runonce -v --no-splay",but the problem still exist. i'm afraid if i explain my question clearly. the "mco puppet runonce -v" command can response ,and puppet agent is invoked immediately.then ,puppet agent will wait for one minute after its first request to puppet master : (172.16.233.110 - - [20/May/2015:09:45:47 +0800] "GET /test/node/test-account-110.web.test.glodon.com?failon404=true&transaction_uuid=32487394-ea0f-4942-95a4-4d259ea6cfb1 HTTP/1.1" 200 4790 "-" "-" 172.16.233.110 - - [20/May/2015:09:47:01 +0800] "POST /test/catalog/test-account-110.web.test.glodon.com HTTP/1.1" 200 34279 "-" "-")

Besides,puppet agent service always keeps running on the agent .

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-05-19 07:53:39 -0500

llowder gravatar image

The -t option is --test, which is a convenience flag to bundle several options, including --no-splay.

With the consistent delay, it is likely that you have splay = true set in your puppet.conf, or if you are using Puppet Enterprise, the puppet agent is not already running when mco is invoked.

If you are using Puppet Enterprise, please refer to the docs for more information.

If you are not, mco puppet runonce -v --no-splay should give you the immediate response that you seek.

edit flag offensive delete link more

Comments

thanks for your reply. The problem still exists. I have modified the question, please give me some advice if you have any idea. Thanks.

peier0810 gravatar imagepeier0810 ( 2015-05-20 02:55:53 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-05-19 01:37:23 -0500

Seen: 450 times

Last updated: May 20 '15