Ask Your Question
0

not able to apply module on agent

asked 2015-05-20 09:38:43 -0500

rishibansal02 gravatar image

my site.pp file on puppet master node "aup3072s" { include test include puppetlabs-motd file { '/tmp/hello': content => "Hello, world\n", }

}

when I run below command on a soalris cleint to apply above module, the command is running fine without errors but no file is getting created.

/opt/puppet/bin/puppet agent -t

Info: Retrieving pluginfacts Info: Retrieving plugin Info: Loading facts Info: Caching catalog for aup3072s Info: Applying configuration version '1432132067' Notice: Finished catalog run in 1.42 seconds #

please help as I am stuck here

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2015-05-22 03:42:30 -0500

rishibansal02 gravatar image

Thanks Hypnoz for your reply. The issue is resolved as I put the site.pp not in the default path. After putting in default path it started to work. Thanks again for your reply.

edit flag offensive delete link more
0

answered 2015-05-21 16:07:49 -0500

Hypnoz gravatar image

Try putting this line in your code to give a debug output line

notify{ "I am puppet master $servername": }

If that's working, then something is wrong with your "file" line, and maybe you need something like "ensure => present" https://docs.puppetlabs.com/reference...

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-05-20 09:38:43 -0500

Seen: 135 times

Last updated: May 22 '15