Ask Your Question
0

install module via rpm-> behind a proxy

asked 2013-06-19 01:09:33 -0500

cko gravatar image

updated 2013-06-19 01:15:40 -0500

hi,

I'm trying to run the following manifest on my puppet agent: (snippet)

   package { 'check_mk-agent-logwatch-1.2.3i1-1.noarch':
      provider => 'rpm',
      ensure   => installed,
      source   => 'http : // mathias-kettner.de/download/check_mk-agent-logwatch-1.2.3i1-1.noarch.rpm',
      require  => Package['xinetd']
   }

(please note that i had to change the link in the manifest because of insufficient karma.

This results in an error:

Execution of '/bin/rpm -i http : //mathias-kettner.de/download/checkmk-agent-1.2.3i1-1.noarch.rpm' returned 1: curl: (7) couldn't connect to host error: skipping http : //mathias-kettner.de/download/checkmk-agent-1.2.3i1-1.noarch.rpm - transfer failed

Now here is the clue ... (more)

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2013-06-20 04:56:55 -0500

cko gravatar image

i solved it by managing the /usr/lib/rpm/macros file with puppet. (added a proxy)

edit flag offensive delete link more
0

answered 2013-06-19 03:10:13 -0500

deric gravatar image

Try setting proxy in your /etc/puppet/puppet.conf

http://docs.puppetlabs.com/references/latest/configuration.html#httpproxyhost

  • http_proxy_host
  • http_proxy_port
edit flag offensive delete link more

Comments

Unfortunately i get this error after i add these lines: Error: Failed to apply catalog: 404 "Not Found" Error: Could not send report: 404 "Not Found"

cko gravatar imagecko ( 2013-06-19 04:29:45 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-06-19 01:09:33 -0500

Seen: 1,303 times

Last updated: Jun 20 '13