Ask Your Question
1

Is stdlib compatible with Puppet 4.x?

asked 2015-05-30 11:38:16 -0500

Herr-Herner gravatar image

As stated by Puppet the (current) version 4.6 of stdlib is not compatible with Puppet 4. I have checked most of my dependencies and all of them seem to be compatible with Puppet 4. The problem is that some of them depend on stdlib.

What are the limitations of version 4.6 on Puppet 4? Is the current snapshot in the master branch of stdlib compatible with Puppet 4?

We will setup our Puppet environment soon and I would appreciate to start directly with Puppet 4.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-05-31 22:05:48 -0500

GregLarkin gravatar image

It looks like you'll have to wait for stdlib 5.x before the module is compatible with PE 4.0. I expect that would have to happen around the same time as the PE 4.0 release because so many of the Puppet-supported modules depend on stdlib, and it's a supported module itself.

There is further information here: https://github.com/puppetlabs/puppetlabs-stdlib/tree/master#version-compatibility

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-05-30 11:38:16 -0500

Seen: 597 times

Last updated: May 31 '15