Ask Your Question
0

Server hostname did not match server certificate

asked 2015-06-04 02:07:06 -0600

valHALLuh gravatar image

I installed Puppet Enterprise on two virtual machines (one master and one node). When I try to run my agent manually with puppet agent -t i get the error Server hostname '192.168....' did not match server certificate; expected one of host-192-168-.....localdomain. If i run this by adding --server host-192-168.....localdomain it works, but this way i can do this manually and after it's own runInterval it doesn't work so on my puppet console it says it is Unresponsive. I guess this is because on its own it gets the error i mentioned earlier so my master can't receive any reports from this node. Can someone please help me with this? How can i make so my node's agent is contacting the master with the proper server certificate name? Thank you in advance.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2015-06-04 08:18:46 -0600

abhishek gravatar image

updated 2015-06-04 08:20:58 -0600

I'm guessing that you're missing the server config in your agents puppet.conf.

You can include the server ="your master" in the AGENT section of your node in /etc/puppet/puppet.conf assuming you're using open source puppet.

You may also try this:- "puppet config set server "your master" --section agent" on your agent node

edit flag offensive delete link more
0

answered 2015-06-11 01:56:00 -0600

shirish shukla gravatar image

/etc/puppet/puppet.conf
server = "fqdn of master" <- FQDN not IP

Also, ensure Both master and agent hostname get resolve from both end correct entry in /etc/hosts file .

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2015-06-04 02:07:06 -0600

Seen: 4,951 times

Last updated: Jun 11 '15