Ask Your Question

puppet get stuck when triggered by mcollective

asked 2015-06-08 07:32:12 -0600

peier0810 gravatar image

When I use mco command like mco puppet runonce -v -F computer_ip='', I fount that it always takes about 75 seconds for puppet to complete its job. I checked the puppet_access log and it showed like this: - - [08/Jun/2015:19:20:00 +0800] "GET /test/node/ HTTP/1.1" 200 4797 "-" "-" - - [08/Jun/2015:19:21:13 +0800] "POST /test/catalog/ HTTP/1.1" 200 843 "-" "-" - - [08/Jun/2015:19:21:15 +0800] "PUT /test/report/ HTTP/1.1" 200 20 "-" "-".

every time it took about 75 seconds between GET and POST.

But if I do not use mco command and just run puppt agent, everything works fine.

This problem has puzzled me for a long time, I really hope someone can give me some advice.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2015-06-08 11:48:16 -0600

arussell gravatar image

I believe splay is enabled by default for the puppet agent.
You can try this to see if it helps.

mco puppet runonce --no-splay -v -F computer_ip=''


edit flag offensive delete link more

answered 2015-06-09 06:07:27 -0600

is the puppet service on the client running or stopped when this happens? if puppet is already running then mco should start a puppet run pretty much straight away, if puppet is stopped then I believe the node(s) will splay their timing over a two minute period (it looks like this is whats happening) - you can set a force=true here to get it to run immediately. Cheers Stuart

edit flag offensive delete link more


Thanks for your advice. I have tried to use --no-splay but the problem still exist...

peier0810 gravatar imagepeier0810 ( 2015-06-09 10:12:54 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2015-06-08 07:32:12 -0600

Seen: 107 times

Last updated: Jun 09 '15