Ask Your Question
0

Getting Error 400 on SERVER: Could not find terminus puppetdb for indirection facts

asked 2015-06-11 08:11:09 -0500

Mohan Sanagapalli gravatar image

I am having a solo setup where both master and agent are installed on a single node. While trying to connecting the master i am getting this error.

$ bundle exec puppet agent --test --server xxxxxxx   
Warning: Unable to fetch my node definition, but the agent run will continue:   
Warning: Error 400 on SERVER: Could not find terminus console for indirection node  
Info: Retrieving pluginfacts  
Info: Retrieving plugin  
Error: Could not retrieve catalog from remote server: Error 400 on SERVER: Could not find terminus puppetdb for indirection facts  
Warning: Not using cache on failed catalog  
Error: Could not retrieve catalog; skipping run

I installed puppet from source code (Puppet version-4.1,ruby-2.1) , any pointers or any help would be great ..!!!

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2015-06-11 21:40:32 -0500

cbarbour gravatar image

You have PuppetDB configured on the Puppet Master, but did not install the PuppetDB terminus. Check puppet.conf, routes.yaml, and puppetdb.conf for references to PuppetDB on your Puppetmaster. You might also have to disable storeconfigs.

If you find no settings, on the master also try puppet master --genconfig and check the output for information on storeconfigs and PuppetDB.

edit flag offensive delete link more
0

answered 2016-10-14 04:15:28 -0500

ynux gravatar image

Thanks. I couldn't find anything in the config files, but puppet master --genconfig really helped because it explains

    # Whether to store each client's configuration, including catalogs, facts,
# and related data. This also enables the import and export of resources in
# the Puppet language - a mechanism for exchange resources between nodes.
#
# By default this uses the 'puppetdb' backend.
#
# You can adjust the backend using the storeconfigs_backend setting.
# The default value is 'true'.
storeconfigs = true
# Configure the backend terminus used for StoreConfigs.
# By default, this uses the PuppetDB store, which must be installed
# and configured before turning on StoreConfigs.
# The default value is 'puppetdb'.
storeconfigs_backend = puppetdb

So either prepare a backend, or disable storeconfigs and do a service puppetserver force-reload. Thinking about it, I do want to use storeconfigs, and will go with puppetdb.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-06-11 08:11:09 -0500

Seen: 2,892 times

Last updated: Jun 11 '15