Ask Your Question

Vagrant boxes passwords not working

asked 2015-06-17 08:03:42 -0600

ChristheDBA gravatar image

I am attempting to setup vagrant dev boxes from the Atlas site. I am using the "official" images from Puppetlabs and have tried the default password 'vagrant' and the password I found by googling 'puppet'? Is there an updated password or should I use a different method of access?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2015-06-17 12:10:00 -0600

GregLarkin gravatar image

You should be able to "vagrant ssh" to get into the machine. Once you're in, "sudo su" to get to root. From there, you can change the password to any account.

You should also be able to ssh in with vagrant/vagrant, but you'll have to connect to the proper port number that vagrant configures as it boots the VM.

edit flag offensive delete link more


I do not agree that this is the correct way to make a vagrant box. According to Hashicorp's official documentation, the root password should be `vagrant`

felipe1982 gravatar imagefelipe1982 ( 2015-07-29 21:13:45 -0600 )edit

1) The boxes have been updated since this report; still don't work. 2) There is a well documented way to build a vagrant box; puppet is not following it. 3) Vagrant ssh does not work; the putty suggestion does not work. Suggestion: do it right or don't do it at all. It's not that hard.

David Lee Crites gravatar imageDavid Lee Crites ( 2016-09-16 17:48:08 -0600 )edit

answered 2015-09-09 15:57:17 -0600

password authentication is not working on those boxes.

If you use putty, the private_key provided by vagrant isn't recognized, putty cannot handle it.

Please use the following website to get it fixed. Worked for me!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2015-06-17 08:03:42 -0600

Seen: 2,812 times

Last updated: Jun 17 '15