Ask Your Question
0

Puppet Agent Cert issues

asked 2015-06-18 08:19:12 -0500

sysman gravatar image

Hello all, playing around with the new puppetserver and agent and I am having an issue with the agent talking to the master. I keep getting the below error and I am stumped as to where it might be.

Error: Could not request certificate: Find /puppet-ca/v1/certificate/ca?environment=production&failon404=true resulted in 404 with the message: <html> <head> <meta http-equiv="Content-Type" content="text/html;charset=ISO-8859-1"/> <title>Error 404 </title> </head> <body>

HTTP ERROR: 404

Problem accessing /puppet-ca/v1/certificate/ca. Reason:

    Not Found


Powered by Jetty:// </body> </html> I am running 3 VirtualBox VM's with CentOS 7 installed. I can get puppet to work using the old 3.8 version no problem. I can even have the 3.8 client talk with the new server and it works. By using the old puppet, I have established that I can communicate with all my VM's inside virtualbox. I think the issue might be with retrieving the CA info, but not sure.

Thanks

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2015-06-18 11:44:36 -0500

sysman gravatar image

After doing a uninistall and installing the 4.1 packages my issue seems to be fixed.. not sure why I was having the issue in the first place.. sorry for the bother.

edit flag offensive delete link more
0

answered 2015-06-20 04:38:53 -0500

Anwar gravatar image

in your puppetmaster, did you added

certname = <puppet.certificate.name.pam>

to the main part of your configuration file /etc/puppet/puppet.conf

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-06-18 08:19:12 -0500

Seen: 2,409 times

Last updated: Jun 20 '15