Ask Your Question

Puppet agent won't connect to puppet master

asked 2015-06-22 22:52:33 -0500

Anthony57 gravatar image

I want to apply a manifest. I am running open source puppet 3.4.3 on the puppet master and puppet agent nodes. I had one manifest work before. Apparently some changes have been made. I have SSH certificates configured on the puppet agent server and the puppet master server.

Here is the command I ran from the puppet agent server (running Ubuntu):

sudo puppet agent --test --verbose --server

This is the output that I saw:

Warning: Unable to fetch my node definition, but the agent run will continue:
Warning: getaddrinfo: Name or service not known
Info: Retrieving plugin
Error: /File[/var/lib/puppet/lib]: Failed to generate additional resources using 'eval_generate': getaddrinfo: Name or service not known
Error: /File[/var/lib/puppet/lib]: Could not evaluate: getaddrinfo: Name or service not known Could not retrieve file metadata for puppet:// getaddrinfo: Name or service not known

Error: Could not retrieve catalog from remote server: getaddrinfo: Name or service not known
Warning: Not using cache on failed catalog
Error: Could not retrieve catalog; skipping run
Error: Could not send report: getaddrinfo: Name or service not known

What is wrong? Why cannot getaddrinfo be evaluated? Rebooting the servers didn't help.

edit retag flag offensive close merge delete


Does resolve to anything?

giavac gravatar imagegiavac ( 2015-06-23 03:38:58 -0500 )edit

try telnet 8140 or ping to see you get expected output ..........if it throws the error then add the host entry in /etc/hosts file (<correctip> and then try - Cheers

scm_questor gravatar imagescm_questor ( 2015-06-23 07:23:26 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2017-12-07 05:09:15 -0500

manoharreddyg gravatar image

Try this if you face any connection error. Agent -> sudo rm -rf /var/lib/puppet/ssl Master -> sudo rm -rf /var/lib/puppet/ssl/certificate_requests/* agent -> sudo puppet agent --server pupet.master.server --waitforcert 60 --test

check on master the puppet agent is connected or not (sudo puppet cert list --all) . If it not connected then try to run the below command. master -> sudo puppet cert sign -a

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2015-06-22 22:52:33 -0500

Seen: 5,160 times

Last updated: Dec 07 '17