Cannot connect to active directory - error message cut off

asked 2015-06-24 17:33:30 -0600

erhama gravatar image

Hello,

I recently installed puppet enterprises and I am attempting to connect to our domain controller. However when attempt to connect I get the following.

Error connecting to LDAP server: an error occurred while attempting to connect to server HostnameOfOurServer:389:java.net.SocketExc

My first thoughts were perhaps a firewall issue or maybe I fat fingered something, however after installing telnet on the puppet master server I tested telnet to our DC on port 389 and was able to get through, so I don't think anything is being blocked.

Is there any way to see the full error string? or is this message being written to a log somewhere? Part of the problem is I cannot see the full error message so I don't know where to start.

I've tried putting the correct password and complete jibberish in the password field, also tried putting in the correct ldap string and an incorrect string in the lookup user field, however I get the same first half of the error message every time so i'm not quite sure what part of my configuration is causing this error.

Thanks for the help guys!

edit retag flag offensive close merge delete

Comments

Still trying to figure out what is causing this just wanted to bump this post to see if anyone had any advice.

erhama gravatar imageerhama ( 2015-07-24 11:06:31 -0600 )edit

Since you didn't post any code, I'm just confused on if you're simply adding the server to AD or using a module. If this is a module, did you try running "puppet agent -t --debug --logdest /tmp/puppetlog.txt"?

johnnyb04 gravatar imagejohnnyb04 ( 2015-07-26 00:33:22 -0600 )edit