Ask Your Question
1

In which file do I specify node-ttl?

asked 2015-06-29 14:22:00 -0600

thewellington gravatar image

I am running Puppet Enterprise 3.7

In which file on the master do I specify the node-ttl directive in order to have puppet automatically deactivate nodes?

I have tried in /etc/puppetlabs/puppet/puppet.conf to specify:

[database]
    node-ttl = 90d

but puppet complained that declaring environments in puppet.conf was deprecated.

I also tried putting it in /etc/puppetlabs/puppet/puppetdb.conf but all my nodes began to fail their puppet runs.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-07-01 07:23:52 -0600

bhanu.rhce gravatar image

Can you pls try to put that config in "database.ini" in "/etc/puppetlabs/puppetdb/conf.d/" & check if it solves your problem?

pls refer: http://docs.puppetlabs.com/puppetdb/1...

hope it helps

Thanks!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-06-29 14:22:00 -0600

Seen: 237 times

Last updated: Jul 01 '15