Ask Your Question
1

puppetlabs-registry module not showing up in console.

asked 2015-06-30 12:43:26 -0500

jgoodyear gravatar image

I am able to install using "puppet module install puppetlabs-registry" If I execute "puppet module list" I get the following. /etc/puppetlabs/puppet/environments/production/modules helloworld (???) puppetlabs-powershell (v1.0.4) puppetlabs-registry (v1.1.0) puppetlabs-stdlib (v4.6.0)

I have verified the files and folders were created in /etc/puppetlabs/puppet/environments/production/modules However when I go to the console and try and create a class, it will not show up. the stdlib will but both powershell and registry will not. I have added other modules and they have all shown up any suggestions? I am running Puppet Ent 3.8.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2015-06-30 16:08:15 -0500

jgoodyear gravatar image

What i found is the Quick Start Guide for Windows no longer functions due to changes made in the latest registry module. The default init.pp was removed in that revision. Which stops the quick start demo from working. However, you can create your own puppet file which calls one of the defined resources in the manifest folder. This will allow you to create registry entries or modify existing.

edit flag offensive delete link more
0

answered 2016-03-17 05:55:00 -0500

garfius gravatar image

Happens to me too.

I want to start testing i maybe developing for puppet, and this is a setback. Also had to add 'service pe-console-services restart' at rc.local on my centos 7 testing VM, and the VM doesn't power off correctly since i used 'puppet-enterprise-installer'.

So, what shall i have to do?, please help.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-06-30 12:40:57 -0500

Seen: 412 times

Last updated: Mar 17 '16