Ask Your Question
0

Could not find class reboot

asked 2015-07-13 04:47:03 -0500

shivakumar gravatar image

updated 2015-07-21 05:28:18 -0500

I am getting the below error message on one of my host.

C:\>puppet agent -t
Info: Retrieving pluginfacts
Info: Retrieving plugin
Info: Loading facts
Could not retrieve fact='konductor_repository_ip', resolution='<anonymous>': undefined method 
`ipaddress_local_area_connection' for Facter:Module
Error: Could not retrieve catalog from remote server: Error 400 on SERVER: Could not find class reboot for VM-D00584.xx.xx.xx.xx.com on node VM-D00584.xx.xx.xx.xx.com
Warning: Not using cache on failed catalog
Error: Could not retrieve catalog; skipping run

But on master i see reboot module is installed:

Modules Installed on Puppet Master:

/etc/puppet/modules
....
âââ puppetlabs-reboot (v1.0.0)
....

Puppet Conf files are:

[main]
    server = vm-d00548.xxx.xxx.xxx.xxx

    # The Puppet log directory.
    # The default value is '$vardir/log'.

    logdir = /var/log/puppet


    # Where Puppet PID files are kept.
    # The default value is '$vardir/run'.
    rundir = /var/run/puppet

    # Where SSL certificates are kept.
    # The default value is '$confdir/ssl'.
    ssldir = /var/lib/puppet/ssl
    modulepath = /etc/puppet/modules
    basemodulepath = /etc/puppet/modules
    pluginsync = true

[agent]
    server = vm-d00548.xxx.xxx.xxx.xxx
    # The file in which puppetd stores a list of the classes
    # associated with the retrieved configuratiion.  Can be loaded in
    # the separate ``puppet`` executable using the ``--loadclasses``
    # option.
    # The default value is '$confdir/classes.txt'.
    classfile = $vardir/classes.txt

    # Where puppetd caches the local configuration.  An
    # extension indicating the cache format is added automatically.
    # The default value is '$confdir/localconfig'.
    localconfig = $vardir/localconfig
edit retag flag offensive close merge delete

Comments

OK I edited the post. :)

Alex Harvey gravatar imageAlex Harvey ( 2015-07-21 05:29:07 -0500 )edit

3 Answers

Sort by » oldest newest most voted
0

answered 2015-08-21 04:26:02 -0500

prachi gravatar image

I ran into similar issue 'could not find class reboot' when tried to deploy modules on windows puppet agent.

C:\Windows\system32>puppet agent -t

Info: Retrieving pluginfacts Info: Retrieving plugin Info: Loading facts Could not retrieve fact='konductorrepositoryip', resolution='<anonymous>': und efined method `ipaddresslocalarea_connection' for Facter:Module Error: Could not retrieve catalog from remote server: Error 400 on SERVER: Could not find class reboot for vm-d02043.xx.xx.xx.xx.com on node vm-d02043.xx.xx.xx.xx.com Warning: Not using cache on failed catalog Error: Could not retrieve catalog; skipping run

Master details:

Open source puppet master version 3.8.2 installed on CentOS 6.5

Configuration file path: /etc/puppet/puppet.conf

[main]

server = vm-d00693.xx.xx.xx.com

# The Puppet log directory.
# The default value is '$vardir/log'.
logdir = /var/log/puppet

# Where Puppet PID files are kept.
# The default value is '$vardir/run'.
rundir = /var/run/puppet

# Where SSL certificates are kept.
# The default value is '$confdir/ssl'.
ssldir = /var/lib/puppet/ssl
modulepath = /etc/puppet/modules
pluginsync = true

[agent]

server = vm-d00693.xx.xx.xx.com
# The file in which puppetd stores a list of the classes
# associated with the retrieved configuratiion.  Can be loaded in
# the separate ``puppet`` executable using the ``--loadclasses``
# option.
# The default value is '$confdir/classes.txt'.
classfile = $vardir/classes.txt

# Where puppetd caches the local configuration.  An
# extension indicating the cache format is added automatically.
# The default value is '$confdir/localconfig'.
localconfig = $vardir/localconfig

Manifests path: /etc/puppet/manifests/site.pp

node default {

include iox

include reboot

}

Package {

  allow_virtual => false,

}

Modules path: /etc/puppet/modules/

.. ├── puppetlabs-reboot (v1.1.0) ..

Windows Agent details:

open source puppet agent version 3.7.4 on windows server 2012 x64

Config file path: C:\ProgramData\PuppetLabs\puppet\etc\puppet.conf

[main]

server=vm-d00693.xx.xx.xx.com

pluginsync=true

autoflush=true

archive_files=true

archivefileserver=vm-d00693.xx.xx.xx.com

graph=true

environment=production

noop = true

I tried installing puppetlabs-reboot module on windows agent but the problem persists. Why is it not able to pick up the module from master? Is it open source problem? Please help me out.

edit flag offensive delete link more
0

answered 2015-07-14 20:22:13 -0500

updated 2015-07-21 05:34:15 -0500

Please try to format your posts so that people can understand your output. Also, provide your puppet.conf files from the agent and master, and what version of puppet are you using.

UPDATE

First thing I notice is that you seem to have the 'server' setting incorrect; that should be the hostname of your puppet master.

Also, can you update the post to make it clear where the puppet master's puppet.conf file ends, and where the agent's puppet.conf file begins - or did you only paste one?

Thanks.

edit flag offensive delete link more
0

answered 2016-08-31 04:37:38 -0500

Envek gravatar image

In my case that was locale issues on puppet master (some of my manifests contains localized comments).

Check output of locale command in console (should not complain about anything).

Fixed it by running sudo dpkg-reconfigure locales and inserting next lines to /etc/default/locale:

LC_ALL="ru_RU.UTF-8"
LANG="ru_RU.UTF-8"
LANGUAGE="ru_RU:ru:en"
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-07-13 04:47:03 -0500

Seen: 350 times

Last updated: Jul 21 '15