Ask Your Question
0

default_manifest variable not updating

asked 2015-07-20 12:33:33 -0500

FJ40 gravatar image

I have setup two Ubuntu 14.04 VMs with Puppet 3.8.1. One as a master and the other as an agent. For whatever reason when I set the default_manifest variable in puppet.conf is does not seem to do anything.

[main]
logdir=/var/log/puppet
vardir=/var/lib/puppet
ssldir=/var/lib/puppet/ssl
rundir=/var/run/puppet
factpath=$vardir/lib/facter
templatedir=$confdir/templates
default_manifest = /etc/puppet/manifests/site.pp
[master]
# These are needed when the puppetmaster is run by passenger
# and can safely be removed if webrick is used.
ssl_client_header = SSL_CLIENT_S_DN
ssl_client_verify_header = SSL_CLIENT_VERIFY
# default_manifest = /etc/puppet/manifests/site.pp

I've bounced puppet, but even still I get this:

fj40@puppetmaster:/etc/puppet$ puppet config print manifest --section master
/home/fj40/.puppet/manifests/site.pp

I'm not sure why it's trying to pull it from my home. I don't even have a .puppet folder

edit retag flag offensive close merge delete

Comments

did you run the puppet command as root? Run the puppet command as root or use sudo: sudo puppet config print manifest --section master

maynero gravatar imagemaynero ( 2015-07-20 14:07:59 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-07-22 03:05:55 -0500

what Mayanero says is correct:

as non root:

puppet config print manifest /home/stuart/.puppet/manifests/site.pp

as root:

puppet config print manifest /etc/puppetlabs/puppet/environments/production/manifests (which is what I have in puppet.conf)

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-07-20 12:33:33 -0500

Seen: 105 times

Last updated: Jul 22 '15