pe-httpd service is not running

asked 2015-08-03 02:55:01 -0500

updated 2015-08-03 12:47:39 -0500

csharpsteen gravatar image

Hi,

I am facing issue in starting up pe-httpd service due to certificate mismatch.

By mistake i did "puppet cert clean --all" which cleaned up all the certificates. Afterwards, Agent was not able to communicate with Master. Hence i tried to regenerate the certificate by following the steps listed in: http://docs.puppetlabs.com/pe/latest/...

In the above link, it shows ./opt/puppetlabs/server/data/console-services/certs/*. But in my PE master setup(3.8.1 (Puppet Enterprise 3.8.1)), i am not able to find /opt/puppetlabs at all. Please suggest me the appropriate document to regenerate the certificate.

Error log in pe-httpd : Unable to configure RSA server private key [Mon Aug 03 07:42:02 2015] [error] SSL Library Error: 185073780 error:0B080074:x509 certificate routines:X509checkprivate_key:key values mismatch

Regards, Gnana

edit retag flag offensive close merge delete

Comments

The "latest" docs are currently for PE 2015.2 which has a different directory layout. Since you're running PE 3.8.1, try these docs: http://docs.puppetlabs.com/pe/3.8/trouble_regenerate_certs_monolithic.html#step-4--clear-and-regenerate-certs-for-the-pe-console

csharpsteen gravatar imagecsharpsteen ( 2015-08-03 12:49:16 -0500 )edit