puppet 4.2

asked 2015-08-06 08:28:52 -0600

hiero_nymus gravatar image

updated 2015-08-06 08:30:26 -0600

Hi, I need to install puppet4.2 server on a machine where previously was puppet agent 3.7.x. First, I've update the agent up to 3.8.x. Now, I've installed the repo:

rpm -ivh puppetlabs-release-pc1-el-6.noarch.rpm

I've seen that puppet has update following packages:

puppet-agent
hiera
facter

Now, when I couldn't start the puppetserver service puppetserver start The actual ruby version is :

# ruby --version
ruby 1.8.7 (2013-06-27 patchlevel 374) [x86_64-linux]]

Is a ruby's version problem or what could be the problem?? I've spend still many hours to find this problem and I don't know any more whas to check? Has anyone experience with 4.2??

Thankx and best regards

edit retag flag offensive close merge delete

Comments

Please post a link to a pastebin of the error messages you see when you try to start puppetserver. That may help troubleshoot the problem.

GregLarkin gravatar imageGregLarkin ( 2015-08-07 14:03:45 -0600 )edit