Ask Your Question
0

I am getting below error while installing 'rack passanger'

asked 2015-08-10 10:02:30 -0500

kailas kadam gravatar image

root@station1 ~]# gem install rack passanger
WARNING: RubyGems 1.2+ index not found for:

RubyGems will revert to legacy indexes degrading performance. ERROR: Could not find a valid gem 'rack' (>= 0) in any repository WARNING: RubyGems 1.2+ index not found for:

RubyGems will revert to legacy indexes degrading performance. ERROR: Could not find a valid gem 'passanger' (>= 0) in any repository

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-08-12 04:14:11 -0500

I suspect this is your .gemrc file.

easiest way is to remove the address your command fails on - go through .gemrc and remove URLs till command works .. also I'm assuming here you have access to internet on this machine and dont need to open a firewall / proxy

cheers Stuart

edit flag offensive delete link more

Comments

Thanks a lot for your revert i am very new to puppet stuff could you please let me know what i need to remove sorry for asking

kailas kadam gravatar imagekailas kadam ( 2015-08-12 09:07:30 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-08-10 10:02:30 -0500

Seen: 83 times

Last updated: Aug 12 '15