Ask Your Question
0

Regarding "puppetlabs-node_openstack"

asked 2015-08-12 07:44:27 -0500

tux gravatar image

updated 2015-08-12 13:43:07 -0500

Hi all, I installed "Puppet" on a CentOS-6.7 (32 bit) VM. The version details are as;

# cat /etc/centos-release 
CentOS release 6.7 (Final)
# puppet -V
3.8.2

#rpm -qa | grep puppet

puppetlabs-release-5-11.noarch
puppet-server-3.8.2-1.el5.noarch
puppet-3.8.2-1.el5.noarch

(Note: I encountered the same with puppetlabs-release-6x, so I tried to see if it works with a lower version)


# puppet module list
/etc/puppet/modules
├── puppetlabs-cloud_provisioner (v1.1.4)

└── puppetlabs-node_openstack (v0.0.4)
/usr/share/puppet/modules (no modules installed)

# puppet help node_openstack
Error: Could not autoload puppet/face/node_openstack/list_keynames: no such file to load -- fog
Error: Could not load help for the face node_openstack.
Please check the error logs for more information.
Detail: "Could not autoload puppet/face/node_openstack/list_keynames: no such file to load -- fog"
Error: Try 'puppet help help help' for usage

The command "puppet help", ouputs the following error as well (excerpt only)

! node            ! Subcommand unavailable due to error. Check error logs.
! node_aws        ! Subcommand unavailable due to error. Check error logs.
! node_gce        ! Subcommand unavailable due to error. Check error logs.
! node_openstack  ! Subcommand unavailable due to error. Check error logs.

Note: I tried to install FOG but that required me to update Ruby to 1.9.3 and then to 2.0.0, but neither of these resolved the issue;

# rvm list
rvm rubies
 * ruby-1.9.3-p551 [ i686 ]
=> ruby-2.0.0-p643 [ i686 ]

# => - current
# =* - current && default
#  * - default

Eventually I reverted back to Ruby 1.8.x

Could someone please help me fix this please or help me know if that module actually works with the current version of Puppet that I am having.

Thanks in advance!

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2015-08-15 00:40:09 -0500

tux gravatar image

Just to update the thread,

I was able to get rid of the errors when I tried the same on a Ubuntu 14.04.1 LTS vm.

root@ubuntu:~# puppet -V
3.8.2


root@ubuntu:~# puppet help node_openstack

USAGE: puppet node_openstack <action> <--endpoint ENDPOINT> 

This subcommand provides a command line interface to manage Openstack
machine instances. The goal of these actions is to easily create new
machine and tear them down when they're no longer
required.

OPTIONS:
  --render-as FORMAT             - The rendering format to use.
  --verbose                      - Whether to log verbosely.
  --debug                        - Whether to log debug information.
  --endpoint ENDPOINT            - Nova API server that services vm management
                                   requests

ACTIONS:
  create           Create a new machine instance.
  list             List machine instances.
  list_images      List available images.
  list_keynames    List available key names.
  terminate        Terminate machine instance.

See 'puppet man node_openstack' or 'man puppet-node_openstack' for full help.
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-08-12 07:44:27 -0500

Seen: 121 times

Last updated: Aug 15 '15