Unable to establish SSL connection

asked 2015-08-14 13:58:57 -0500

parajaganesh gravatar image

updated 2015-08-14 22:15:21 -0500

GregLarkin gravatar image

We are having Puppet Enterprise master configured on a RHEL 6.6 machine. While trying to install Puppet agent on a Solaris however getting "Unable to establish SSL connection" error.

/usr/sfw/bin/wget https://uppetserver:8140/packages/current/install.bash
--2015-08-14 13:24:44--  https://puppetserver:8140/packages/current/install.bash
Resolving puppetserver... 13.121.221.68
Connecting to puppetserver|13.121.221.68|:8140... connected.
Unable to establish SSL connection.
edit retag flag offensive close merge delete

Comments

Can you reinvoke with "wget --verbose" and post the output here?

GregLarkin gravatar imageGregLarkin ( 2015-08-14 22:17:33 -0500 )edit

I am using solaris 10 sparc. bash-3.2# /usr/sfw/bin/wget --verbose wget: missing URL Usage: wget [OPTION]... [URL]... Try `wget --help' for more options. bash-3.2# The help shows --verbose but could not able to run it.

parajaganesh gravatar imageparajaganesh ( 2015-08-17 06:35:42 -0500 )edit

I meant add the "--verbose" option to the original command that you invoked above, e.g. "wget --verbose https://....". That way, we should be able to see more of the communication between the node and the Puppet master.

GregLarkin gravatar imageGregLarkin ( 2015-08-18 11:42:33 -0500 )edit