Ask Your Question
0

Installing last version of Puppet Server on Ubuntu 14.04.2 - Failed

asked 2015-08-16 05:40:51 -0600

Sarsa-JP gravatar image

Guys, I'm having a hard time trying to get the last version of Puppet Server installed on Ubuntu Trusty 14.04.2 LTS. After the installation, I run the command to start the service, which the system does, but when I run a command with puppetmaster the system says:

`puppetserver: command not found`

I'm sure I'm missing something here, but couldn't figure out, or find any document to solve this.

I have followed the steps described here:

http://docs.puppetlabs.com/puppetserv...frompackages.html

I did all the pre-installation tasks, and I'm running this machine in a VM in Virtual Box with nothing else in it. After the setup of the repositories which I followed this guide:

https://docs.puppetlabs.com/guides/pu...packagerepositories.html#apt-based-systems

I executed the following commands successfully:

wget https://apt.puppetlabs.com/puppetlabs-release-pc1-trusty.deb
sudo dpkg -i puppetlabs-release-pc1-trusty.deb
sudo apt-get update

Then I executed the installation command:

apt-get install puppetserver

I didn't get any error message after the installation and after that I setup the amount of memory as recommended in this page:

http://docs.puppetlabs.com/puppetserv...frompackages.html#memory-allocation

Edited this file:

/etc/default/puppetserver

And my setup looks like this:

JAVA_ARGS="-Xms512m -Xmx512m"

This is the only change I did after the instalation, and I also tried to run again without the changes. Can you guys please advise or send me to a place where I can find the solution for this?

Best regards.

edit retag flag offensive close merge delete

Comments

1

What command line are you executing that is resulting in the `command not found` message? Is it something like `service puppetserver start`?

csharpsteen gravatar imagecsharpsteen ( 2015-08-16 16:39:04 -0600 )edit

I'm trying to run all sets of command line that takes 'puppetserver'. For example: puppetserver <subcommand> [<args>] as explained at the docs. Finally one of the commands is: puppetserver --verbose --no-daemonize which generates output 'command not found' On Ubuntu and CentOS7.

Sarsa-JP gravatar imageSarsa-JP ( 2015-08-16 17:21:32 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-08-17 00:21:23 -0600

cprice404 gravatar image

You should check the log files in /var/log/puppetlabs/pupppetserver/puppetserver.log to see if the server is starting successfully. (You could also use netstat or telnet to see if it is listening on port 8140.)

In recent versions of Puppet, the command-line tools are installed in a directory like /opt/puppetlabs/bin, which may not be automatically added to your $PATH, so you may need to add that directory to your path or use the fully qualified path when calling the command-line command.

Lastly, the --verbose and --no-daemonize arguments are for the older Puppet masters; the command-line subcommands available for the new Puppet Server can be found here:

https://docs.puppetlabs.com/puppetser...

edit flag offensive delete link more

Comments

Hey Mr. Price! You nailed it! I checked the environment variables and it seems that the path for the /opt/puppetlabs/bin was not set. So now I can run the commands and study a little bit more before making the purchase decision for our PRD. Thanks!

Sarsa-JP gravatar imageSarsa-JP ( 2015-08-17 04:55:34 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-08-16 05:40:51 -0600

Seen: 788 times

Last updated: Aug 17 '15