Ask Your Question
0

Install Chocolatey package what is syntax for source?

asked 2015-08-20 14:52:45 -0500

bvi1998 gravatar image

updated 2016-10-07 13:15:03 -0500

Hi, I am testing the following...

class nsclient64 {
        package { 'nsclient64':
                ensure          => '1.0.0.1',
                provider        => 'chocolatey'
                source          => 'http://servername:81/nuget/puppet',
                install_options => ['-y'],
        }
}

I am getting an error message: Error: Could not parse for environment production: Syntax error at 'source'; expected '}' at /etc/puppet/environments/test/modules/nsclient64/manifests/init.pp:5

what is the proper way to install a NuGet or Chocolatey package from a NuGet feed?

I am a newbie :)

Thanks!

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2015-08-20 21:33:01 -0500

lavaman gravatar image

You are missing a comma between 'chocolatey' and source.

You will of course need a puppet module that provides the chocolatey package provider.

edit flag offensive delete link more

Comments

Duh, thanks. Gepetto didn't even see it. Now it can't find the chocolatey provider... working on that next :) Thanks

bvi1998 gravatar imagebvi1998 ( 2015-08-21 08:58:02 -0500 )edit
0

answered 2015-10-27 09:28:27 -0500

bvi1998 gravatar image

if my package name is nsclient64.1.0.0.1.nupkg, is below still the proper way to reference the package name?

class nsclient64 { package { 'nsclient64': ensure => '1.0.0.1', provider => 'chocolatey' source => 'http://servername:81/nuget/puppet', install_options => ['-y'], } }

Thanks for your help!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2015-08-20 14:52:45 -0500

Seen: 327 times

Last updated: Oct 07 '16